Go Down

Topic: Problems with 0021 on Ubuntu 10.04 Lucid Lynx (Read 28 times) previous topic - next topic

muscatelle

Thanks for the advice, -  I'm brand new to arduino and am just trying to get my first board up and running. I reckon I put the board into DFU mode and ran the three commands

sudo dfu-programmer at90usb82 flash --debug 1 Arduino-usbserial-uno.hex responded with:

"Error parsing the line.
Something went wrong with creating the memory image."

dmesg now shows the board is detected on connect, but no
"cdc_acm 2-2:1.0: ttyACM0: USB ACM device" msg is produced, and of course the IDE does not recognise the board.

Would welcome any advice
TIA



stimmer

Possibly the file got corrupted when you downloaded it. Could you run:

md5sum Arduino-usbserial-uno.hex

You should get 5680a78c5a9c386914923e39022318cc or 8e01ee236e70bbea43f7eb4e11c9688a, if you got anything else then download it again.

muscatelle

The checksum of the file I've newly downloaded is:
b19b169d3bbe069d847830b0d6ec67c6  Arduino-usbserial-uno.hex

Looks like the downloaded files have changed in the last 8 hrs or so.
The result is still the same.

stimmer

The second checksum I gave was the one updated a few hours ago. It's definitely getting corrupted on download. What does the file look like in a text editor? (It is an ascii file)

muscatelle

Problem partly solved

The file I was saving was actually the html file pointing to the hex file and it was named  ' Arduino-usbserial-uno.hex'.  Worked out that "raw" was the actual hex file to download.

However the IDE will still not write to the serial port.  On powering up a second time both the IDE and dmesg indicate that ACM0 is the active port.

However compiling and attempting to upload the sketch "Fade" results in the following error:

Binary sketch size: 1230 bytes (of a 32256 byte maximum)
processing.app.SerialException: Error opening serial port '/dev/ttyACM0'.
     at processing.app.Serial.<init>(Unknown Source)
     at processing.app.Serial.<init>(Unknown Source)
     at processing.app.debug.Uploader.flushSerialBuffer(Unknown Source)
     at processing.app.debug.AvrdudeUploader.uploadViaBootloader(Unknown Source)
     at processing.app.debug.AvrdudeUploader.uploadUsingPreferences(Unknown Source)
     at processing.app.Sketch.upload(Unknown Source)
     at processing.app.Sketch.exportApplet(Unknown Source)
     at processing.app.Sketch.exportApplet(Unknown Source)
     at processing.app.Editor$DefaultExportHandler.run(Unknown Source)
     at java.lang.Thread.run(Thread.java:636)
Caused by: gnu.io.UnsupportedCommOperationException: Invalid Parameter
     at gnu.io.RXTXPort.setSerialPortParams(RXTXPort.java:171)
     ... 10 more
processing.app.debug.RunnerException: Error opening serial port '/dev/ttyACM0'.

At which point  /dev/ttyACM0 drops from the IDE.
Restarting the IDE restores /dev/ttyACM0.

Go Up