Pages: 1 [2]   Go Down
Author Topic: Problems with Eclipse installing AVR plug-in  (Read 7830 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 18
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ralph,

I am successfully using Eclipse Helios with the AVR Eclipse plugin.
The Arduino Mega uses an ATmega1280 microcontroller at 16MHz, so make sure you choose that when configuring your project.

To upload to the Arduino Mega, you need to go to Windows, Preferences, AVR, AVRDude, Programmer Configurations, Add.

Then select "Arduino" from Programmer Hardware, set the port to the serial port your Arduino shows up as (under Windows, you can find this by going to the device manager). Set the baud rate to 57600 and leave the other parameters alone.

Now go to your project, properties, AVR, AVRDude, and choose the programmer configuration you just created from the list.

You should now be able to upload to the board. Compile your project, then make sure that the project is selected in Project Explorer (typically the leftmost panel). Right click on the project, then select AVR, Upload to board (you can add this as a toolbar button too) to upload.

If you get STK500 protocol errors, it's possible the timeout on resetting the board is not appropriate for you. Experiment by manually resetting the board and hitting the upload button.

I hope this helps.

PS. You may be interested in MHVlib, a runtime library for AVRs, developed in Eclipse. You can grab the Eclipse project from http://www.makehackvoid.com/group-projects/mhvlib-efficiency-oriented-library-avr-microcontrollers
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 2
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks for the information... The question I am dealing with is the "Configuration". Basically I understand all that you say, and maybe I'll give it a shot on Windows, but for now I am trying to get this up on UBUNTU. I can compile a project, I can see the AVRDude plug in stuff in my Eclipse IDE, and I can initiate an upload but it will fail.

The Linux version of the AVR instructions talks about a configuration/properties file, but the example does not show my model of Arduino, and is lacking of any documentation on how to set this part of the project up.

It sounds to me like the Windows AVRDude / Eclipse plug in has a better way to configure the project?
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 18
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

AVR Eclipse gets the list of programmers by issuing "avrdude -c ?". If your avrdude install is too old, it will not have the Arduino protocol listed in the output of that command.

Check that you are running the latest AVRDude (5.10) and update to it if not. The avrdude config that ships with the install should already have the appropriate lines for the Arduino.

Here is the config I have for the Arduino. Note that the protocol specified is Arduino, which needs to be compiled in:

programmer
  id    = "arduino";
  desc  = "Arduino";
  type  = arduino;
;
Logged

Pages: 1 [2]   Go Up
Jump to: