Pages: [1]   Go Down
Author Topic: The problem with PD(pure data)  (Read 693 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello,
  
 I use arduino(usb) with max/msp. If I use arduino with max, it works very well, but I tried with PD, it doesn't work. I used two patch who names are Pduino-0.2 and Arduino2PD. But I can't use.  
 
 When I tried with Pduino, I uploaded pd_firmware to the board and I turned it on and arduino-test.pd. And I changed serial port, even port#15,  
 
When I change the serial port Pd sad,  
 
 
** ERROR ** could not open device /dev/ttyS1:
 failure(2): No such file or directory
 
 
** ERROR ** could not open device /dev/ttyS2:
 failure(2): No such file or directory
 
etc..
 
And if I write #16 on the serial port,
 
It say
 
comport open 6959828, baud 1 not valid (args: [portnum] [baud])
 
  
 
 Do I must install some patch on PD? Just I use Pd extended and I didn't install any patch.  
Because I saw 'ilstall-notes' in pduino,  
 
Pduino needs the following externals and abstractions:
 
[arduino], from pd-cvs/externals/hardware/arduino
[comport], from pd-cvs/externals/iem/comport
[speedlim], from iemlib, pd-cvs/externals/iemlib
 
If I need externals, where do I take that? I think there is external -'comport' in Pd extended, but I don't know another.
 
 How can I use that?
 
 thank you.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello, I think you've got to check if your arduino is really connected to /dev/ttyS1.  On my computer it's on /dev/ttyUSB0. Also on your pd patch you could try to send a higher number to open the serial port, it range from 0 to 7 but it could be more. You can look in the PD-list , it has been discussed. Hope it helps you.
Logged

Pages: [1]   Go Up
Jump to: