Pages: [1]   Go Down
Author Topic: HiloUpgrader trouble  (Read 681 times)
0 Members and 1 Guest are viewing this topic.
Landskrona
Offline Offline
Newbie
*
Karma: 0
Posts: 31
Google is your mother's friend
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi!
Hope this is the correct place to ask about this.
I have the Hilo gprs module from Libelium and want to upgrade to new firmware. But when i start HiloUpgrader.exe it only trows a error on MFC42.DLL. I have tried to replace the .dll with the one followed in the HiloUpgrader-v1.0.0.0-Pack that I found on this forum with no results at all. Any one here that knows anything about this problem?
I have contacted Libelium but they say I should talk to Sagem so now im trying to get in touch with them but im testing here at the same time (Sagem support seems really slow).
Logged

Landskrona
Offline Offline
Newbie
*
Karma: 0
Posts: 31
Google is your mother's friend
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I found out that MFC42.dll has a close relationship with Visual C++ so I uninstalled my Visual C++, rebooted, renamed the old MFC42.dll and copied the one that I got with HiloUpgrader-v1.0.0.0-Pack and BOOM, HiloUpgrader started like a charm  8-)
« Last Edit: September 19, 2009, 02:54:14 pm by SteNull » Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 7
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

How did you manage to upgrade the module?
How did you set the DTR to GND? (as far as I know the Libelium PCB does not contain a DTR line).
When I run the tool, although I use the right COM port and speed (did AT+IPR=115200, tried also messing with AT&D and AT&K to trick the PC software).
Nothing worked.
I'm affraid to use the "Force Download' optino since it cannot really communicate with my board.
Ihave a4.006 revision.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 7
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I don't have visual C++ on my machine and yet i still cant get the hilo upgrader to work, i just get an error saying ordinal not found. i have tried replacing the .dll file but it made no difference.

Also, has anyone had the problem of when you using the ardunio to send run skech such as for sending an sms message it does not pick up the ok commands from the gprs module. I can send a message from the Hyperterminal but not from the arduino. :o Has anyone else experienced this?? :-?  
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 7
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

have a look here for upgrading info.
http://www.libelium.com/squidbee/index.php?title=Uploading_the_firmware
Logged

Pages: [1]   Go Up
Jump to: