Go Down

Topic: Setting up MS Visual Studio to compile/upload? (Read 3625 times) previous topic - next topic

TimL(UK)

By the way the avr compiler does not like spaces in folder names. So your sketch folders folders should not be in a folder such as MyDocuments\Visual Studio 2010\Projects

I will shortly make a version that copies a project to a temp folder prior to compile. This will avoid the problem.

So right now you should be able to open a .pde and a project/solution should automatically be created for you. You should then see the tool bar with the arduino boards button. If you have spaces in the .pde folder name then you will get an error when you click compile.

I assume you have the addin enabled and have set the visual micro options




TimL(UK)

Byt he way have you set the PDE file extension in the Visual Studio > options > text editor?

Might be best to use the visualmicro forum if you can. New updates are posted there

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy