Pages: [1]   Go Down
Author Topic: Minicom doesn't pick up serial communication  (Read 2089 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 18
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Long time lurker, first time being an OP. I've searched high and low for an answer, and I'm finally resorting to any help this gracious community can offer.

I have grand plans in mind, but being new to the Arduino, I'm attempting baby steps. eventually I want the arduino to communicate via the rx/tx lines to my own personal software project. As a first step, I wanted to see if I could get the arduino to send data to minicom, a solid well known cmd line program for serial communication. However even that first step has failed, and I really don't know why.

Here is what is running on the arduino, put there by the 018 IDE running on OSX.

#include <NewSoftSerial.h>

NewSoftSerial mySerial(2, 3);

void setup()  
{

  Serial.begin(4800);
  mySerial.begin(4800);
}

void loop()
{
  Serial.println("Hello, world!");
     mySerial.println("Hello, world?");
     delay(500);
}


Here is what I know:
The USB cable is connected, and the Arduino serial monitor picks up the traffic over the USB cable.
I am wired rx <--> tx and vice-versa
The baud rates are matched on the sending and receiving.
minicom is in a state of "OFFLINE", which has something to do with a DCD line?
The tx LED on the arduino fires repeatedly with the proper delay.

My knowledge of serial communication and minicom are close to nil. It's probably a settings problem, but I can't for the life of me figure it out, or find someone else that has explained it.

Any help out there?
Logged

Boston, MA
Offline Offline
Edison Member
*
Karma: 0
Posts: 1024
wiblocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I use minicom with my boards and haven't had a problem.
I placed some mincom usage hints in my datasheets.
Go to http://wiblocks.luciani.org/ZB1/ZB1-index.html
and click on the datasheet link and go to the minicom
section.

HTH.

(* jcl *)

------------------------------------
www: http://www.wiblocks.com
twitter: http://twitter.com/wiblocks
blog: http://luciani.org
Logged


0
Offline Offline
Newbie
*
Karma: 0
Posts: 18
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks for the quick reply!

I took a look through the datasheets, and there is some good info in there. However the one other thing besides baud rate that I KNOW is correct is the device/port number.

I'm making a new cable now, just to eliminate that as a potential problem. However I've gone through my breadboard and wires with a multi meter to make sure things are going where I think they should be. Not that it's in the least bit complicated  :-?
And sorry about not using a CODE tag, but I wasn't sure what it is on this board, and out of the half million buttons I don't see one for adding code tags smiley-sad
Logged

Left Coast, CA (USA)
Offline Offline
Brattain Member
*****
Karma: 361
Posts: 17294
Measurement changes behavior
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

You do know that you can't have both the Arduino serial monitor and Minicom active on the same comm port at the same time? Just had to ask cause it wasn't clear from your post that you aren't trying to do that, otherwise never mind.  smiley-wink

Lefty
« Last Edit: May 10, 2010, 12:50:50 am by retrolefty » Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 18
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I'm open to all suggestions and clarifications!

I'm aware that one can't have both the Arduino USB serial AND pin 0 and 1 (tx/rx) active at the same time. That is correct?
That's the reason the code is what it is right now. I don't have an independent power source at the moment, so I need the USB plugged in for power.

But if you mean on the receiving end using the same port, I can assure you it's two different ports, because it's two different hardware devices smiley
« Last Edit: May 10, 2010, 01:10:05 am by Earendil » Logged

Left Coast, CA (USA)
Offline Offline
Brattain Member
*****
Karma: 361
Posts: 17294
Measurement changes behavior
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ok, no problem. It's just still not clear to me what you have set-up in the hardware, perhaps a block diagram? Are your using Minicom on a different PC then the one the Arduino board is wired to ?

Lefty

Logged

Pages: [1]   Go Up
Jump to: