Go Down

Topic: Xbee dilema (Read 676 times) previous topic - next topic


I have 2 XBee modules, and the sparkfun regulated breakout board, and the USB breakout board so i can attach to a computer.  The following happens on both boards when attached to the compute

i am able to
a) test with XCTU and it reads the device fine
b) i can read the device configuration, and write it as well.

in both cases the TX and RX leds on the breakout board blink.

However, from the terminal window, no matter what I try I can't get anything back (sending +++ should give me OK, but I get nothing, same happens with hyperterm or any other terminal emulator).  Range test in loop back mode also does not work, i get receive timeout errors, and the RSSI led never lights up.  I've put the latest firmware from Digi

These are XBee24  Version 10E8 devices.

Any ideas.

I;ve also tried to interface with a sketch, and still get nothing from the device, the


b) i can read the device configuration, and write it as well.

So, apparently the configurations on the two XBees are not compatible. What Function Set are you using on each one? What series XBees are they? What values are you setting? PAN ID? MY? DH? DL?
The art of getting good answers lies in asking good questions.


I'm not changing any of the parms.. i;m just reading and then writing them back out to the device.

I'm just trying to get the single device to respond to AT commands from a terminal, not even trying to send data between the devices.

Both are XB24 (from xctu modem configuration) function set Xbee 802.15.4 version 10E8

Nothing has been changed, these are exactly what they were configured to out of the box.

from my reading.  if i send +++ to the single device it should respond with OK
sending ATID should give the id that it is configured.

I get nothing from the device, but clearly xctu is doing this when testing from the test/query button on the PC settings since its getting the data back to identify the device.

Go Up