Pages: 1 [2]   Go Down
Author Topic: Square or Sinewave  (Read 1789 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 12
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello Trialex,
Your right, it was in the wrong place so I created a directory in 'My Documents' named Arduino and another directory inside that called Libraries. I downloaded a new zip of FrequencyTimer2 there and extracted it. Still the same compiler errors.
Thanks for your suggestions,
Curtis
Logged

London
Offline Offline
Faraday Member
**
Karma: 8
Posts: 6240
Have fun!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
I created a directory in 'My Documents' named Arduino…
Hmm… the Arduino directory should already be there, that is where all the sketches you have created should be stored.  If you needed to create the arduino directory then something is in the wrong place.

Have a look at the preferences tab (from the file menu in the IDE) and see where the IDE thinks your sketch files should be stored. This directory should already have existed. As mentioned in an earlier post,  you should create the library directory (if it did not already exist) under the Arduino subdirectory indicated in the IDE.

Once you get the directories sorted you should delete any old copies of FrequencyTimer2 that may be in other directories so there is one copy.
For example of  your arduino sketchbook location is:
C:\Documents and Settings\YourNameHere\My Documents\Arduino

Then there should be a subdirectory under this called Libraries :
  …\My Documents\Arduino\Libraries

And a subdirectory under this called FrequencyTimer2 that has the .cpp and .h files
  …\My Documents\Arduino\Libraries\FrequencyTimer2\ FrequencyTimer2.cpp
  …\My Documents\Arduino\Libraries\FrequencyTimer2\ FrequencyTimer2.h

You should delete any other copies of FrequencyTimer2 that may be in the directory where you installed your arduino runtime code.
« Last Edit: October 08, 2009, 09:28:10 am by mem » Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 12
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello,
I deleted all references to arduino. I then downloaded the latest arduino from the site. I created a directory named Arduino in My Documents and extracted the files there. There was no subdirectory named Libraries in there. There was one in the subdirectory named Hardware. I created a subdirectory in ..My Documents\Arduino\ called libraries. I then extracted the FrequencyTimer2 files into this place. ..My Documents\Arduino\Libraries\FrequencyTimer2\

Still the same. I googled this library and saw that many people were having the same problems. Same errors with no solution.
Thanks,
Curtis
Logged

London
Offline Offline
Faraday Member
**
Karma: 8
Posts: 6240
Have fun!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Have you checked that the copy of FrequencyTimer2 is the correct version  (see my earlier post for what to look for)
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 12
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello,
I want to thank everyone for their help thus far. I ordered a breakout board that was suggested: http://www.sparkfun.com/commerce/product_info.php?products_id=9116

It came in and it looks promising. From reading the datasheet, I think it uses I2C. I believe the wire library will work. I have a Duemilanove. The pins are SDA=Pin4, SCL=Pin 5 for that board? Any help would be greatly appreciated since I am still learning this great product (Arduino).
Thanks,
Curtis
Logged

Pages: 1 [2]   Go Up
Jump to: