Go Down

Topic: Pro Tools Rec Light (Read 6392 times) previous topic - next topic

Grumpy_Mike

#30
Oct 30, 2017, 01:02 pm Last Edit: Oct 30, 2017, 01:02 pm by Grumpy_Mike
Quote
I copied your code but it keeps giving me this error message:
Well I have just tried compiling the code for a Teensy 3.2 and I got no error message at all. I suspect you haven't copied it correctly. I am using Arduino 1.8.4

Diamondj421

I'm VERY new to Arduino and completely lost. My girlfriend made a "RECORDING" light for me for my birthday with a remote but I'd rather have it turn on and off when I press record in Pro Tools 12. I have an Arduino R3 Plus and a Sainsmart relay. I also have all of the components to make a MIDI circuit but would rather have this operate via MIDI USB. Could someone explain to me how to connect the Arduino to the relay and then what code to install? Also where would I connect the cable running from the light itself? Pretend you're explaining it to a 5 year old. Lol. Thanks!

Rockmaclu

I am having a issue using HIDUINO. Pro Tools doesn't seem to send anything to my board. Did you change any configuration in PT? I can make it work sending raw MIDI CC Messages with MIDI-OX. Do you have any new code? Did you try using a MIDI Shield?

Thanks :)

Diamondj421

I couldn't get it to work so I threw in the towel. If you get it working though, PLEASE let me know!

gabermusic

 I'm still pretty stupid at programming languages so won't be able to help you with coding. All I know is the code that was written by Mr. Grumpy Mike. I changed some values (all the changes are in the thread). Then (after testing it with midi shield) I turned my arduino to (I believe) Hiduino. After that arduino was plugged via USB and was recognized by  computer as midi device.
  You have to configure your DAW. In Peripherals choose midi controller (hiduino). Under type choose HUI. After that PT will send midi data to your device. Just in case: the values in code correspond only to HUI protocol. It won't work with BABY HUI or Mackie (it's confusing but will work with MACKIE HUI in Cubase).

Diamondj421

#35
Jul 29, 2018, 06:07 am Last Edit: Jul 29, 2018, 10:47 am by Diamondj421
I got it working! Now, in Pro Tools 12, the pan faders are randomly changing for some reason. Almost as if there was automation on the track. It doesn't happen if I unplug the Arduino so it has something to do with that.  Any idea what could be causing this?

UPDATE: This appears to be happening whenever I commit or render a track. It only seems to be affecting whatever the 6th track is on my edit window though.  Very odd. Or is it?

Rockmaclu

I'm still pretty stupid at programming languages so won't be able to help you with coding. All I know is the code that was written by Mr. Grumpy Mike. I changed some values (all the changes are in the thread). Then (after testing it with midi shield) I turned my arduino to (I believe) Hiduino. After that arduino was plugged via USB and was recognized by  computer as midi device.
  You have to configure your DAW. In Peripherals choose midi controller (hiduino). Under type choose HUI. After that PT will send midi data to your device. Just in case: the values in code correspond only to HUI protocol. It won't work with BABY HUI or Mackie (it's confusing but will work with MACKIE HUI in Cubase).
THANKS A LOT. It was this problem. Now it works perfectly. :)

Diamondj421

Are you not having the issues with the pan fader shifting? If so, could you send me the exact sketch that you used? I'm so lost. Thanks!

Go Up