Go Down

Topic: Mysterious Verify Exit (Read 692 times) previous topic - next topic

jmpalazz

I'm running the Arduino IDE on my laptop and seeing an issue that I don't see on my desktop.  I did a fresh install of version 1.6.11 and did not install any boards or libraries.  I click "Verify" or Ctrl-R the basic sketch that is loaded when the IDE is started.  With verbose mode ON, the compile starts, then gives me an exit status 1.

I can click "Verify" multiple times, and it will exit at multiple places in the compile.  It usually exits with a status of 1, but sometimes gives a large negative number (i.e. -1073741819).  It even, rarely, successfully completes the compile.

Here is a "typical" output:
Code: [Select]

Arduino: 1.6.11 (Windows 7), Board: "Arduino/Genuino Uno"

C:\Program Files (x86)\Arduino\arduino-builder -dump-prefs -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -hardware C:\Users\jmpalazz\AppData\Local\Arduino15\packages -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -tools C:\Users\jmpalazz\AppData\Local\Arduino15\packages -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\jmpalazz\Documents\Arduino\libraries -fqbn=arduino:avr:uno -ide-version=10611 -build-path C:\Users\jmpalazz\AppData\Local\Temp\buildb4eebe1f4cbb459938137b403b1c57ac.tmp -warnings=none -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avr-gcc.path=C:\Users\jmpalazz\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\4.9.2-atmel3.5.3-arduino2 -prefs=runtime.tools.avrdude.path=C:\Users\jmpalazz\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino6 -verbose C:\Users\jmpalazz\AppData\Local\Temp\untitled860004783.tmp\sketch_oct18a\sketch_oct18a.ino
C:\Program Files (x86)\Arduino\arduino-builder -compile -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -hardware C:\Users\jmpalazz\AppData\Local\Arduino15\packages -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -tools C:\Users\jmpalazz\AppData\Local\Arduino15\packages -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\jmpalazz\Documents\Arduino\libraries -fqbn=arduino:avr:uno -ide-version=10611 -build-path C:\Users\jmpalazz\AppData\Local\Temp\buildb4eebe1f4cbb459938137b403b1c57ac.tmp -warnings=none -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avr-gcc.path=C:\Users\jmpalazz\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\4.9.2-atmel3.5.3-arduino2 -prefs=runtime.tools.avrdude.path=C:\Users\jmpalazz\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino6 -verbose C:\Users\jmpalazz\AppData\Local\Temp\untitled860004783.tmp\sketch_oct18a\sketch_oct18a.ino
Using board 'uno' from platform in folder: C:\Users\jmpalazz\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.14
Using core 'arduino' from platform in folder: C:\Users\jmpalazz\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.14
Detecting libraries used...
"C:\Users\jmpalazz\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\4.9.2-atmel3.5.3-arduino2/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics  -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10611 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR   "-IC:\Users\jmpalazz\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.14\cores\arduino" "-IC:\Users\jmpalazz\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.14\variants\standard" "C:\Users\jmpalazz\AppData\Local\Temp\buildb4eebe1f4cbb459938137b403b1c57ac.tmp\sketch\sketch_oct18a.ino.cpp" -o "nul"
"C:\Users\jmpalazz\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\4.9.2-atmel3.5.3-arduino2/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics  -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10611 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR   "-IC:\Users\jmpalazz\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.14\cores\arduino" "-IC:\Users\jmpalazz\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.14\variants\standard" "C:\Users\jmpalazz\AppData\Local\Temp\buildb4eebe1f4cbb459938137b403b1c57ac.tmp\sketch\sketch_oct18a.ino.cpp" -o "nul"
Generating function prototypes...
"C:\Users\jmpalazz\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\4.9.2-atmel3.5.3-arduino2/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics  -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10611 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR   "-IC:\Users\jmpalazz\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.14\cores\arduino" "-IC:\Users\jmpalazz\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.14\variants\standard" "C:\Users\jmpalazz\AppData\Local\Temp\buildb4eebe1f4cbb459938137b403b1c57ac.tmp\sketch\sketch_oct18a.ino.cpp" -o "C:\Users\jmpalazz\AppData\Local\Temp\buildb4eebe1f4cbb459938137b403b1c57ac.tmp\preproc\ctags_target_for_gcc_minus_e.cpp"
"C:\Program Files (x86)\Arduino\tools-builder\ctags\5.8-arduino10/ctags" -u --language-force=c++ -f - --c++-kinds=svpf --fields=KSTtzns --line-directives "C:\Users\jmpalazz\AppData\Local\Temp\buildb4eebe1f4cbb459938137b403b1c57ac.tmp\preproc\ctags_target_for_gcc_minus_e.cpp"
Compiling sketch...
"C:\Users\jmpalazz\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\4.9.2-atmel3.5.3-arduino2/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -MMD -flto -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10611 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR   "-IC:\Users\jmpalazz\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.14\cores\arduino" "-IC:\Users\jmpalazz\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.14\variants\standard" "C:\Users\jmpalazz\AppData\Local\Temp\buildb4eebe1f4cbb459938137b403b1c57ac.tmp\sketch\sketch_oct18a.ino.cpp" -o "C:\Users\jmpalazz\AppData\Local\Temp\buildb4eebe1f4cbb459938137b403b1c57ac.tmp\sketch\sketch_oct18a.ino.cpp.o"
Compiling libraries...
Compiling core...
"C:\Users\jmpalazz\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\4.9.2-atmel3.5.3-arduino2/bin/avr-gcc" -c -g -x assembler-with-cpp -flto -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10611 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR   "-IC:\Users\jmpalazz\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.14\cores\arduino" "-IC:\Users\jmpalazz\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.14\variants\standard" "C:\Users\jmpalazz\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.14\cores\arduino\wiring_pulse.S" -o "C:\Users\jmpalazz\AppData\Local\Temp\buildb4eebe1f4cbb459938137b403b1c57ac.tmp\core\wiring_pulse.S.o"
"C:\Users\jmpalazz\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\4.9.2-atmel3.5.3-arduino2/bin/avr-gcc" -c -g -Os -w -std=gnu11 -ffunction-sections -fdata-sections -MMD -flto -fno-fat-lto-objects -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10611 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR   "-IC:\Users\jmpalazz\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.14\cores\arduino" "-IC:\Users\jmpalazz\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.14\variants\standard" "C:\Users\jmpalazz\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.14\cores\arduino\WInterrupts.c" -o "C:\Users\jmpalazz\AppData\Local\Temp\buildb4eebe1f4cbb459938137b403b1c57ac.tmp\core\WInterrupts.c.o"
exit status 1
Error compiling for board Arduino/Genuino Uno.


Anyone have any ideas I can try to get the IDE compiling on my laptop?

Go Up