Go Down

Topic: IDE 1.8.0 Released -- update: 1.8.7 (Read 91922 times) previous topic - next topic

Ryansand

i just unistalled 1.8.0 and now have 1.8.5 but get this error just trying to compile a program.
My online arduino editor compiled however. Please help! want to just go back to my old editor or fix this issue. Below is my error code.

Arduino: 1.8.5 (Windows Store 1.8.10.0) (Windows 10), Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

C:\Users\Ryan Sand\Documents\Arduino\Arduino-Msi\libraries\TestingOnly.ino:69:29: fatal error: SparkFunLSM9DS1.h: No such file or directory

 #include <SparkFunLSM9DS1.h>

                             ^

compilation terminated.

exit status 1
Error compiling for board Arduino/Genuino Mega or Mega 2560.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

pert

When you see a "No such file or directory" error it almost always means you need to install the library that contains the missing file.

Often the code you're compiling will come with documentation (either a comment or separate document) that tells you where to get the library dependencies.

In other cases the author of the code will not have been so kind and you'll need to go on a hunt for the missing library.

A good place to start is the Arduino IDE's Library Manager:
  • Sketch > Include Library > Manage Libraries...
  • In the "Filter your search..." box, type some keywords you have gleaned from the missing file name.
  • Scroll through the results for the right library. Click on it.
  • Click "Install".
  • Wait for installation to finish.
  • Click "Close".
  • Try compiling your code again.


If you have no luck in Library Manager then load up your favorite search engine and do a search for the missing filename. You will often get multiple results. If you have a lot of results you might add "arduino" as an additional search keyword. I will usually prefer results on github.com since that is where most Arduino libraries are hosted and downloading from there is fast and easy. In some cases there will be multiple libraries that contain the given filename and you'll need to do some evaluation to determine which seems the most appropriate, then try it out. After downloading the library you found you'll need to install it. This requires a different process than the Library Manager installation. You will find instructions here:
  • https://www.arduino.cc/en/Guide/Libraries#toc4
  • https://www.arduino.cc/en/Guide/Libraries#toc5


My online arduino editor compiled however.
That's because all the libraries in the Library Manager index are preinstalled in the Arduino Web Editor. When using the real Arduino IDE you need to install the libraries you need, but it's easy enough. Actually the >1500 preinstalled libraries in the Arduino Web Editor is a common cause of problems due to filename collisions.

SharifJami

Arduino: 1.8.5 (Windows 10), Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"




exec: "C:\\Users\\\\Documents\\arduino-1.8.5\\hardware\\tools\\avr/bin/avr-g++":
Error compiling for board Arduino/Genuino Mega or Mega 2560.




Now What ??
I can't fix this. Help me Plz

pert

Help me Plz
Please do this:
  • File > Preferences > Show verbose output during: > compilation (check)  > OK
  • Sketch > Verify/Compile
  • After the compilation fails you'll see a button on the right side of the orange bar "Copy error messages". Click that button.
  • Paste the error messages in a reply here USING CODE TAGS (</> button on the toolbar).

SharifJami

Arduino: 1.8.5 (Windows 10), Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

C:\Users\{( # )}\Documents\arduino-1.8.5\arduino-builder -dump-prefs -logger=machine -hardware

C:\Users\{( # )}\Documents\arduino-1.8.5\hardware -tools C:\Users\{( # )}\Documents\arduino-1.8.5\tools-builder -tools C:\Users\{( # )}\Documents\arduino-1.8.5\hardware\tools\avr -built-in-libraries

C:\Users\{( # )}\Documents\arduino-1.8.5\libraries -libraries

C:\Users\{( # )}\Documents\Arduino\libraries -fqbn=arduino:avr:mega:cpu=atmega2560 -ide-version=10805 -build-path C:\Users\{(#)}~1\AppData\Local\Temp\arduino_build_14524 -warnings=default -build-cache

C:\Users\{(#)}~1\AppData\Local\Temp\arduino_cache_215390 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arduinoOTA.path=

C:\Users\{( # )}\Documents\arduino-1.8.5\hardware\tools\avr -prefs=runtime.tools.avr-gcc.path=

C:\Users\{( # )}\Documents\arduino-1.8.5\hardware\tools\avr -prefs=runtime.tools.avrdude.path=

C:\Users\{( # )}\Documents\arduino-1.8.5\hardware\tools\avr -verbose C:\Users\{( # )}\Documents\Arduino\Blink\Blink.ino

C:\Users\{( # )}\Documents\arduino-1.8.5\arduino-builder -compile -logger=machine -hardware

C:\Users\{( # )}\Documents\arduino-1.8.5\hardware -tools

C:\Users\{( # )}\Documents\arduino-1.8.5\tools-builder -tools

 C:\Users\{( # )}\Documents\arduino-1.8.5\hardware\tools\avr -built-in-libraries

C:\Users\{( # )}\Documents\arduino-1.8.5\libraries -libraries

C:\Users\{( # )}\Documents\Arduino\libraries -fqbn=arduino:avr:mega:cpu=atmega2560 -ide-version=10805 -build-path

C:\Users\{(#)}~1\AppData\Local\Temp\arduino_build_14524 -warnings=default -build-cache

C:\Users\{(#)}~1\AppData\Local\Temp\arduino_cache_215390 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arduinoOTA.path=

C:\Users\{( # )}\Documents\arduino-1.8.5\hardware\tools\avr -prefs=runtime.tools.avr-gcc.path=

C:\Users\{( # )}\Documents\arduino-1.8.5\hardware\tools\avr -prefs=runtime.tools.avrdude.path=

C:\Users\{( # )}\Documents\arduino-1.8.5\hardware\tools\avr -verbose C:\Users\{( # )}\Documents\Arduino\Blink\Blink.ino
Using board 'mega' from platform in folder:

C:\Users\{( # )}\Documents\arduino-1.8.5\hardware\arduino\avr
Using core 'arduino' from platform in folder:

C:\Users\{( # )}\Documents\arduino-1.8.5\hardware\arduino\avr
Detecting libraries used...

"C:\Users\\Documents\arduino-1.8.5\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics  -flto -w -x c++ -E -CC -mmcu=atmega2560 -DF_CPU=16000000L -DARDUINO=10805 -DARDUINO_AVR_MEGA2560 -DARDUINO_ARCH_AVR   "-IC:\Users\\Documents\arduino-1.8.5\hardware\arduino\avr\cores\arduino" "-I

C:\Users\\Documents\arduino-1.8.5\hardware\arduino\avr\variants\mega"

"C:\Users\~1\AppData\Local\Temp\arduino_build_14524\sketch\Blink.ino.cpp" -o "nul"
Generating function prototypes...

"C:\Users\\Documents\arduino-1.8.5\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics  -flto -w -x c++ -E -CC -mmcu=atmega2560 -DF_CPU=16000000L -DARDUINO=10805 -DARDUINO_AVR_MEGA2560 -DARDUINO_ARCH_AVR   "-IC:\Users\\Documents\arduino-1.8.5\hardware\arduino\avr\cores\arduino" "-I

C:\Users\\Documents\arduino-1.8.5\hardware\arduino\avr\variants\mega"

"C:\Users\~1\AppData\Local\Temp\arduino_build_14524\sketch\Blink.ino.cpp" -o

"C:\Users\~1\AppData\Local\Temp\arduino_build_14524\preproc\ctags_target_for_gcc_minus_e.cpp"
exec:

"C:\\Users\\\\Documents\\arduino-1.8.5\\hardware\\tools\\avr/bin/avr-g++": file does not exist
Error compiling for board Arduino/Genuino Mega or Mega 2560.

pert

I'm pretty sure it's your user name {( # )} that's the cause of the problem. If possible, try with another user name that just has only standard letters.

SharifJami

 Yah that's my user name {( # )} :(
I chang it and try
Thank's :) 

SBO

Deseo generar el archivo .hex y para ello edito el archivo preferences.txt cerrando previamente Arduino y añado la linea build.path de acuerc con las instruccciones indicadas en https://conexiona.com/arduino-generacion-archivo-hex/.
Pero cuando abro de nuevo Arduino la linea que he añadido, se ha borrado
Que debo hacer

zoomx

After compiling the sketch don't close the IDE and search in temp folder.
In windows it is
C:\Users\(your username)\AppData\Local\Temp

If you close the IDE this folder will be erased.

gelato2

#189
Jun 29, 2018, 01:54 pm Last Edit: Jun 29, 2018, 01:55 pm by gelato2
Hi I just got a due and i cannot get it to communicate with my PC on windows 10
my uno works perfectly

seems that the PC cannot detect the due on any com port

I am now suspecting that the micro USB cable is not working!

has anyone has this basic problem  - just getting started

many thanks  for any help

Gelato

pert

I am now suspecting that the micro USB cable is not working!

has anyone has this basic problem
Yes. The problem of Arduino boards not being detected due to using a charge-only or defective USB cable is very common. Try using a different cable or verify your cable works for data on another device.

priyasharmma


oqibidipo

#192
Aug 24, 2018, 07:13 am Last Edit: Aug 24, 2018, 07:17 am by oqibidipo

ARDUINO 1.8.6 2018.08.23

[ide]
* Updated arduino-builder to 1.4.0:
- parallel build (improve compile speed)
- better reuse of already compiled files
- Windows: fixed build for sketch stored under OneDrive cloud folders
* Added translations for library types. Thanks @ReAlUA
* Added scroller in programmers menu.
* Added "accelerator" in scrollable menu, press "a" key while scrolling
* Keep "Board Manager" menu item always as first in the menu
* "Manage Libraries" is now also in the "Tools" menu. Thanks @feikname
* Compiler errors now have both column and line
* Serial monitor how has "Show Timestamp" option. Thanks @MichalSy
* Improved DPI detection for hi-resolution montior on Linux
* Added copy/paste contextual menu in Find/Replace text fields
* Fixed long IDE startup time when some virtual/not-connected network interfaces are present
* Fixed inconsistent line-endings when saving files on Windows
* mdns: Make board disappear via TTL instead of reachability. Thanks @kurtgo
* Library Manager: display install/remove buttons with mouse on-hover instead of mouse click
* Board Manager: fixed some rare case with corrupted index download
* Windows: removed some debug output when running the IDE from command line
* Support selectable user-defined themes. User's theme are zip files inside the sketchbook "theme" folder
* Library Manager: library search now search also for headers (.h) declared by the library in library.properties
* Added "--version" to the CLI. Thanks @yohsuke
* Fixed Serial Plotter/Monitor permanently disabled if Plotter fails to open
* Fixed window title that sometimes is not updated on "Save as...". Thanks @JxJxJxMxNxS
* Fixed keybindings for Increase/Decrease font size
* Improved accessibility in the Preferences dialog. Thanks @coreyknapp

[core]
* AVR: Set Optiboot as default bootloader for Nano. This is the bootloader installed on new
     Arduino Nano boards. If you have a Nano with the old bootloader you must select
     Tools > Processor > ATmega328P (Old Bootloader) to upload.
* AVR core has been moved to its own repository: https://github.com/arduino/ArduinoCore-avr
* Updated toolchain to gcc 5.4.0

[wifi101-firmware]
* SECURITY FIX: Released fix for WPA2 KRACK vulnerability (latest WINC1500 firmware 19.5.2).

DaveAhrendt

Discovered that Marlin 3D printer firmware will not compile with 1.8.6.  You get multiple error similar to what I put below.  Rolling back to 1.8.5 everything compiles OK


Sample of the errors:


In file included from C:\Users\Dave\AppData\Local\Temp\arduino_build_700613\sketch\HAL.h:33:0,

                 from C:\Users\Dave\AppData\Local\Temp\arduino_build_700613\sketch\MarlinConfig.h:39,

                 from C:\Users\Dave\AppData\Local\Temp\arduino_build_700613\sketch\Sd2Card.cpp:29:

Sd2Card.h:100:39: error: pasting "/* SPI Master In Slave Out pin*/" and "_DDR" does not give a valid preprocessing token

   #define SPI_MISO_PIN MISO_PIN       // SPI Master In Slave Out pin

                                       ^

C:\Users\Dave\AppData\Local\Temp\arduino_build_700613\sketch\fastio.h:86:42: note: in definition of macro '_SET_INPUT'

 #define _SET_INPUT(IO)        CBI(DIO ## IO ## _DDR, DIO ## IO ## _PIN)

                                          ^

C:\Users\Dave\AppData\Local\Temp\arduino_build_700613\sketch\Sd2Card.cpp:316:3: note: in expansion of macro 'SET_INPUT'

   SET_INPUT(SPI_MISO_PIN);

   ^

C:\Users\Dave\AppData\Local\Temp\arduino_build_700613\sketch\Sd2Card.cpp:316:13: note: in expansion of macro 'SPI_MISO_PIN'

   SET_INPUT(SPI_MISO_PIN);

             ^

Sd2Card.h:100:39: error: pasting "/* SPI Master In Slave Out pin*/" and "_PIN" does not give a valid preprocessing token

   #define SPI_MISO_PIN MISO_PIN       // SPI Master In Slave Out pin



pert

Discovered that Marlin 3D printer firmware will not compile with 1.8.6.  You get multiple error similar to what I put below.  Rolling back to 1.8.5 everything compiles OK
I think this bug will be tracked at:
https://github.com/arduino/Arduino/issues/7930
I originally mistook this for a previously reported issue but after more investigation it appears I was wrong. See my comment here for details:
https://github.com/arduino/Arduino/issues/7930#issuecomment-416079657

Go Up