Go Down

Topic: WaveShield and util.h (Read 2277 times) previous topic - next topic


Jan 21, 2011, 04:56 pm Last Edit: Jan 21, 2011, 04:57 pm by krashe1313 Reason: 1
Sorry if this has been answered before. i promise i searched and searched.

I followed the instructions on the ladyada site and even tried this approach:

in both cases i'm to #include "util.h", which isn't found when compiled. and it's not included with the WaveShield, but that doesn't surprise me as i suspect that "util.h" is a root class, much like "math.h" is.

btw, i searched and searched for "math.h", hoping that if i found that i could figure the location of util.h out. no luck. i know it exists, as i can compile #include "math.h".

a buddy sent me a copy of a program he wrote using the WaveShield, which worked. I've seen, or rather, heard, it. so i know it works for him. soon as i open it i see:
Code: [Select]

#include <AF_Wave.h>
#include <avr/pgmspace.h>
#include <util.h>
#include <wave.h>

sure enough... util.h throws an error.

soooooo.... now what? i'm friggin' stuck! for now i can use a piezo speaker and just play some tones to represent the sound files that should play. so i can still more forward in the meantime, but at some point i'll need to figure out this WaveShield problem.

thanks for your time and help in advance,
shields (kind of a noob)

ps/fyi: i just re-installed my arduino program with the newest version available on the site.


Your operating system? Your buddy's operating system?

On my computer, there is a util.h in the AF_Wave library.


Jan 21, 2011, 05:32 pm Last Edit: Jan 21, 2011, 05:36 pm by krashe1313 Reason: 1
yes, sorry. i'm using a Mac with OS 10 on it here at work. he's using a PC with Windows Vista, I believe, on it.

and i was trying to use the newer WaveHC vs  AF_Wave. Maybe that's the problem.... maybe i inadvertently applied something from one version to the other.

i should go check on that...


Annnnnnnnnddddd.... i've just proven myself to be an idiot!  :o lol

yup. he was using the older version, i downloaded the newer libraries with out realizing he was using the older version. soooo when i tried to  build off of his example, it didn't work.

so that's a huge part of the problem. now that i know i was on the wrong track, let me see if i can get this working now.

thanks for pointing out the error of my ways!

Go Up

Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

via Egeo 16
Torino, 10131