Go Down

Topic: NullPointerException (Read 1 time) previous topic - next topic

merlin981

I just installed 0005, tonight. I already had the latest java runtime installed.

I am getting the following error whenever I try to compile or upload a sketch:

java.lang.NullPointerException
     at processing.app.RunnerException.massage(RunnerException.java:69)
     at processing.app.RunnerException.<init>(RunnerException.java:39)
     at processing.app.Sizer.computeSize(Sizer.java:82)
     at processing.app.Sketch.size(Sketch.java:1660)
     at processing.app.Sketch.handleRun(Sketch.java:1309)
     at processing.app.Editor$34.run(Editor.java:1354)
     at java.awt.event.InvocationEvent.dispatch(Unknown Source)
     at java.awt.EventQueue.dispatchEvent(Unknown Source)
     at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)
     at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
     at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
     at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
     at java.awt.EventDispatchThread.run(Unknown Source)

I have tried loading with and without using run.bat.

Any help would be greatly appreciated.

Thank you

mellis

Does it happen every time you press the compile or upload button?  I've seen cases where this happens the first time you try to compile, but then fixes itself.

drbrian

i am using arduino-0006 with a usb board,
was getting these same errors.
Changed from COM1 to COM3 in the serial port option of the tools menu, No luck.
But when I tried COM4 it did work without error!
Cheers

Go Up