Go Down

Topic: AVR Bootloader burn error in Arduino 9 and 10 (Read 2 times) previous topic - next topic

mellis

The mkII's seem to die relatively easily.  Did you have NG selected in the Boards menu when you burned the bootloader?  If you had Diecimila selected, you'll have the bootloader with a very short timeout, since it's intended for boards that auto-reset.  You should be able to burn the NG bootloader from the IDE.

And yea, there should probably be some sort of progress notification as you burn the bootloader.

glasspusher

Hi Mellis,
Yeah, I tried burning the bootloader as the 168 on an NG board, but so far NG ;) It looks like my mkII is still working, the lights still do their thing and I don't get any error messages, but who knows?

I have 4 diecimila boards on order, they should should be here next week, so even if this doesn't work I won't be out of commision too long.

One other thing I've noticed in my 10 months or so away from this stuff- the sketches I had from version 7, when re-compiled with 8, 9 or 10 are much smaller and didn't work on the NG boards I had with Atmega8 chips. Any ideas?

Thanks!

Dave

mellis

The smaller size is because of some optimizations we did in Arduino 0008.  Did you have the "Arduino NG or Older w/ ATmega8" board selected when you compiled and uploaded the sketches?

David Cuartielles

Dave,

same problem here:

avrdude: stk500v2_command(): command failed
avrdude: initialization failed, rc=-1
        Double check connections and try again, or use -F to override
        this check.



Have tried for both mega8 and mega168 on Windows XP. I am gonna try with the good old command line and report back to the forum ;-)

/d

mellis

Are you using an AVR ISP mkII also?  Let us know how the command line tests turn out.

Go Up