Go Down

Topic: Problems, Problems, Problems (Read 2 times) previous topic - next topic

quackmaster7000

That doesn't work, either. The command prompt comes up with an error that says: "Error occurred during initialization of VM java/lang/NoClassDefFoundError: java/lang/Object. Maybe that'll help...?

mellis

Hmm, sounds like the Java install is messed up.  What is JAVA_HOME set to in the run.bat file?  What happens if you open a command prompt, cd to the Arduino directory, and run "run.bat" from there?  Does java\lib\rt.jar exist?

quackmaster7000

Ok. I cd'd to the directory, and tried to run run.bat. Didn't work; came up with the same error. I also tried to run the arduino exec. from there. Same thing. I checked for the rt.jar file. It was there. Just out of curiosity, I tried to run it. Should it have run properly? Because I tried to run it and it said: "Failed to load Main-Class manifest attribute from [...\...\ directory ---> rt.jar]. Hmmm...

mellis

And what's JAVA_HOME set to in the run.bat file?  You might try putting a semi-colon ";" at the end of the set CLASSPATH= line (after mrj.jar).  Or putting the value assigned to CLASSPATH in "double quotes".  Also, try changing the line:

%JAVA_HOME%\java processing.app.Base

to:

%JAVA_HOME%\java -verbose processing.app.Base

It won't fix anything, but might help us figure out what's wrong.  Try running it again and posting the output here.


quackmaster7000

Erm...I don't quite understand what you're getting at. Could you elaborate a little. Thanks!

Go Up