Go Down

Topic: arduino startup bug (Read 537 times) previous topic - next topic

johnm1019

Feb 02, 2008, 06:43 am Last Edit: Feb 02, 2008, 06:44 am by johnm1019 Reason: 1
After following the Arduino on gentoo guide to the t, on ./arduio i get

java.lang.UnsatisfiedLinkError: /home/jm/arduino-tar/lib/librxtxSerial.so: /home/jm/arduino-tar/lib/librxtxSerial.so: wrong ELF class: ELFCLASS32 (Possible cause: architecture word width mismatch) thrown while loading gnu.io.RXTXCommDriver
Exception in thread "main" java.lang.UnsatisfiedLinkError: /home/jm/arduino-tar/lib/librxtxSerial.so: /home/jm/arduino-tar/lib/librxtxSerial.so: wrong ELF class: ELFCLASS32 (Possible cause: architecture word width mismatch)
       at java.lang.ClassLoader$NativeLibrary.load(Native Method)
       at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1751)
       at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1676)
       at java.lang.Runtime.loadLibrary0(Runtime.java:823)
       at java.lang.System.loadLibrary(System.java:1030)
       at gnu.io.CommPortIdentifier.<clinit>(CommPortIdentifier.java:83)
       at processing.app.Editor.populateSerialMenu(Editor.java:903)
       at processing.app.Editor.buildToolsMenu(Editor.java:800)
       at processing.app.Editor.<init>(Editor.java:190)
       at processing.app.Base.<init>(Base.java:149)
       at processing.app.Base.main(Base.java:104)

thoughts?

I've also tried the export command used in the generic linux guide.

if i try and build from svn i get
jmf-new-desk linux # export CLASSPATH=/opt/blackdown-jre-1.4.2.03/bin:/opt/blackdown-jre-1.4.2.03/lib/rt.jar
jmf-new-desk linux # ./make.sh
Copying shared and core files...
Copying examples...
Copying dist files...
Building the PDE...
tools/DiscourseFormat.java:6: warning: unmappable character for encoding ASCII
 Copyright (c) 2005-06 Ignacio Manuel Gonz?lez Moreta
                                          ^
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
1 warning

Done.

and thats the same whether or not the export line is there.

mellis

Are you on a 64-bit version of Linux?  If so, you'll need to install RXTX yourself.  

johnm1019

#2
Feb 02, 2008, 08:03 pm Last Edit: Feb 02, 2008, 08:03 pm by johnm1019 Reason: 1
Quote
Are you on a 64-bit version of Linux?  If so, you'll need to install RXTX yourself.  

Yes I am on 64 bit. :)

RXTX has  been compiled from source using portage.

$ sudo emerge -vp rxtx
Password:

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] dev-java/rxtx-2.1.7.2-r2  USE="-doc -lfd -source" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB


Do i need to use the -source flag?  Does it have binary components or something?

mellis

Hmm, if you installed your own version of RXTX, you should delete the one that comes with Arduino (RXTXcomm.jar and librxtxSerial.so).

Go Up