Go Down

Topic: arduino svn compile bug (Read 11892 times) previous topic - next topic


If you're having trouble installing avr-libc on your distribution, I'd look for support from the package maintainer.  I don't know anything about it.  
Ok...I'll poke around there.

The repository does unfortunately have a few very large files in it, so it takes a while to check out.  If you're only interested in running Arduino, you should be able to just download the Linux version from the software page.
I'm running an amd64, hence finding this thread...it doesn't work out of the box.


What doesn't work?  You almost certainly don't need to compile Arduino from source.  You probably just need to replace the RXTX library that comes with it with a version that's compiled for 64-bit processors (which you might be able to find a package for).  You might need to compile the Arduino version of avrdude from source, but that won't require checking out the whole (huge) Arduino source tree, just downloading: http://www.arduino.cc/files/avrdude-5.4-arduino-0010-src.tgz


It's working, now -

There are some bugs in the Gentoo ebuilds of the avr libs. A few quick tweaks fixed it and everything runs just fine.


How exactly did you solve the problem? I'm having the same issue here, i'm starting to go crazy. I would be very grateful if you could post the fixes.


Same problem of nphillips and Pu0quoov here... nphillips, you should provide solutions when you find them, or a forum isn't useful :P
I'm trying to figure it out.


Aug 03, 2008, 02:56 pm Last Edit: Aug 04, 2008, 01:01 pm by akiross Reason: 1
A change in crossdev default headers settings worked for me:

Be sure to have mpfr and gmp up to date, they are required for building gcc.

EDIT: I got that working with gcc 4.1.2 and binutils installed with emerge and explicitly set when calling crossdev.
Now I'm looking for an usb cable :D

Go Up