Go Down

Topic: Error on Arduino program start-up (Read 995 times) previous topic - next topic

kats

Nov 18, 2008, 07:25 pm Last Edit: Nov 18, 2008, 07:39 pm by mbkatsus Reason: 1
:(
When ever I try to run Arduino on my Comp (Ver 0012 and Ver 0011), I get the following error:

Error building library "Ethernet"
utility\w5100.c: In function 'wiz_write_buf':
utility\w5100.c:850: internal compiler error: Illegal instruction
Please submit a full bug report,
with preprocessed source if appropriate.
See //sourceforge.net/tracker/?atid=520074&group_id=68108&func=browse for instructions.


I tried Sourceforge for help but could not get anywhere. I use the same program on a diferent comp with celeron processor and it works fine. my comp has VIA samuel processor!!

mellis

Very strange.  If you don't need to use the Ethernet library, you can just delete the hardware/libraries/ethernet sub-directory of the Arduino application directory.

kats

#2
Nov 20, 2008, 10:05 pm Last Edit: Nov 20, 2008, 10:07 pm by mbkatsus Reason: 1
after deleting the ethernet library, this is now the new error:
"error building Library Firmata"
Firmata.cpp: In member function 'void FirmataClass::systemReset()':
Firmata.cpp:451: internal compiler error: Illegal instruction
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://sourceforge.net/tracker/?atid=520074&group_id=68108&func=browse> for instructions.



mellis

What operating system are you using?


kats


mellis

Dunno.  You might try searching for "error: Illegal instruction" and your processor.  Or submitting a bug report to the URL in the error message.

Go Up