Go Down

Topic: processing-arduino-0017 broken in Ubuntu (Read 1 time) previous topic - next topic

Oolong

After much puzzling over the error 'The package "cc" does not exist' I finally figured out that processing-arduino-0017, the only one listed for download here, simply doesn't work in Ubuntu (9.10 or 9.04). Preliminary testing suggests that the previous version of the library works okay, but to find a download link I had to look at the history of the Interface/Processing page!

This has been a problem for at least a few weeks - I'm puzzled that I seem to be the first to report it?

- Oolong

mellis

What if you rename Arduino.jar to arduino.jar?  Or perhaps there's another case problem somewhere?

Oolong

I did try renaming the file, to no avail. Nothing worked short of using the older version of the library.

seej

#3
Mar 31, 2010, 09:36 pm Last Edit: Mar 31, 2010, 11:04 pm by seej Reason: 1
Same problem here. Tried SO many combinations... But, I'm not using ubuntu (or don't think I am...)

Will try the older library.

Ok. Tried that. No luck. Anyone solve this?

I've tried
[username]/documents/processing/sketchbook/library/arduino/arduino.jar
[username]/documents/processing/library/arduino/arduino.jar
[username]/documents/processing/sketchbook/arduino.jar
[username]/documents/processing/library/arduino.jar
[username]/documents/processing/sketchbook/library/arduino/arduino.jar

And soforth. No luck.

Also, I notice that this library is INCLUDED in the standard Processing package: http://processing.org/reference/libraries/

So why do I have to hurt?

[update]
So. I GOT IT WORKING FINALLY!!!!

How? Forget about directories. I kept trying different combinations, caps, versions, etc. No luck. I noticed that I couldn't see the arduino library in "Sketch -> Import Library" (again, even though supposedly this library comes installed with Processing). Beneath that menu choice there's an "add file". I browsed to the latest arduino.jar, and that did the trick. Did this move the file somewhere? Dunno..

Cj

Oolong

Doesn't sound like quite the same problem, given you're not in Ubuntu, but in any case...

One other thing to try - isn't the library supposed to be in the libraries subdirectory of the sketchbook? All your examples show the singular form! Good that you got it working anyway, but even better if you can get to the root cause of it...

seej

I'll check that as well. What's weird is, when I add it, does this get moved to a different location or something? I did a search for the library post-import, to see if the file was copied somewhere; giving clue to my path issue. But, no luck that route either.

Cj

ercolino

#6
Apr 07, 2010, 02:13 am Last Edit: Apr 07, 2010, 02:18 am by ercolino Reason: 1
Hi.

I had the same problem in Mac OSX and solved by renaming the folder  "~/Documents/Processing/libraries/arduino 2" to ".../arduino". That is why it was not found by the import statement.

When you add the Arduino.jar file it gets copied to the sketch folder then it is readily found by the import statement.

Hope it helps in other systems.

dtoliaferro

#7
May 02, 2010, 04:51 am Last Edit: May 02, 2010, 04:52 am by dtoliaferro Reason: 1
This is slightly off topic, but I got the Arduino library to work in Processing using seej's method. So the first thing I did was load the arduino_output example, which allows control of the Arduino through Proccessing. It worked as expected. My question though, is why doesn't it work when I export it as an applet for a browser? I asked this quested about a year ago on the Processing forum, but nobody really had an answer.

Daviz

I got the arduino library running with the hint from mellis. I renamed Arduino.jar to arduino.jar in mysketchesfolder/libraries/arduino/library/ and restarted processing.

Thanks for the help,
David

Go Up
 

Quick Reply

With Quick-Reply you can write a post when viewing a topic without loading a new page. You can still use bulletin board code and smileys as you would in a normal post.

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.

Note: this post will not display until it's been approved by a moderator.
Name:
Email:

shortcuts: alt+s submit/post or alt+p preview