Pages: [1]   Go Down
Author Topic: Shift Backspace  (Read 5221 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 3
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Can you please give me a way to turn off shift-backspace?  I saw an old post from '09 that said to add a line to preferences but this didn't make a difference.  Did this option get removed?  Did it get changed?

Please?
Logged

Seattle, WA USA
Offline Offline
Brattain Member
*****
Karma: 654
Posts: 50958
Seattle, WA USA
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

What is Shift + Backspace doing? That's a pretty tough (for me, anyway) set of keys to accidentally hit together.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 3
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

It operates as delete instead of backspace.  Just put 0022 in to make sure it wasn't a bug in what I had.  No other options anywhere besides the lib folder right?
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 3
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Found it.  I was putting the command "editor.keys.shift_backspace_is_delete = false" in the wrong prefs file.  Found it in C:\Documents and Settings\<user>\Application Data\Arduino and that one worked.  Putting it in the preferences.txt under lib made no difference.
Logged

North Yorkshire, UK
Offline Offline
Faraday Member
**
Karma: 104
Posts: 5531
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ahh, that's where it is... I never got round to turning it off - I will do so now  smiley-grin

Quote
That's a pretty tough (for me, anyway) set of keys to accidentally hit together.
When you're defining things in capitals, people often use shift, if you mess up and press backspace which still holding shift then if 'deletes' instead. Most annoying and it happens rather too frequently.
« Last Edit: January 03, 2011, 06:17:01 am by mowcius » Logged

Pages: [1]   Go Up
Jump to: