Go Down

Topic: road to solve delay on the arduino ide **FAILURE** (Read 4200 times) previous topic - next topic

robert rozee

alas, i can report that with version 0022 of the software, running on an EM350 netbook, NO bluetooth, winXP, the IDE locks up at the introduction screen for approximately a minute before displaying:

"Launch4j
An error occurred while starting the application."

about a further minute after this the IDE does pop up, and appears to function normally without any further slowdowns.

have tried both with the copy of 'rxtxSerial.dll' that comes with 0022, as well as the supposedly fixed one that is available. behaviour is EXACTLY the same with both.

does ANYONE take any interest in fixing these problems? if it is with the serial port enumeration, there should be some way of simply ripping out ALL the associated 'smart' code and dumbly assuming a hard-coded serial comm port.


cheers,
rob


eried

My website: http://ried.cl

robert rozee

given that error and delay coincide 100% on my setup, it is fair to say that they are quite possibly linked. and the delay IS an error, so it really comes down to the finer point of there being 1 or 2 errors.

i did post something to the "issues list" on code.google, but have seen no movement - i presume that forum is dead. i would rate the bug as 'severe', most certainly a show stopper in any of the commercial environment i have worked as a software test engineer. i did offer on code.google to provide any assistance i could in nailing down the issue(s), but, of course, got no reply.

a cursory look at the application shows (simply looking at the DLLs accompanying it) that the code both (a) knows about comm ports, and (b) knows about usb devices. this is a red flag, there should at the least be switches or methods that can be used to disable one or the other, and to force comms to a FIXED device location (ie comm1:, /dev/tty or whatever).


cheers,
rob   :-)

BenF

If you already have a Java runtime on your computer, I would rename the java folder from the Arduino distribution to make sure no attempt is made to load two versions. You may then have to reboot and try again.

robert rozee

#4
Jan 05, 2011, 03:43 pm Last Edit: Jan 06, 2011, 05:14 am by robert_rozee Reason: 1
tried renaming the java folder. alas, it had no effect...

is there any way the arduino IDE can be persuaded to write out a debug log file as it starts up?

eried

You can use process monitor and process explorer to see where it fails.
My website: http://ried.cl

robert rozee

excellent idea.

what are "process monitor" and "process explorer"? google doesn't give me any definitive clues - i'm assuming/hoping they are utilities for monitoring the progression of a java application as it runs.

eried

They are generic debugging/diagnosis tools, from Microsoft/Sysinternals. However they aren't to easy to understand, but you may get a nice picture about whats happening.

Also, are you tried to launch arduino.exe with --l4j-debug args?
Code: [Select]
c:\program files\arduino\arduino.exe --l4j-debug

From console. Check the log file created in c:\program files\arduino\
My website: http://ried.cl

robert rozee

the file "launch4j.log" contains the following:

CmdLine:      C:\Documents and Settings\admin\My Documents\Arduino\arduino-0022\arduino.exe --l4j-debug  
WOW64:            no
Working dir:      C:\Documents and Settings\admin\My Documents\Arduino\arduino-0022\.
Bundled JRE:      java
Check launcher:      C:\Documents and Settings\admin\My Documents\Arduino\arduino-0022\java\bin\javaw.exe (n/a)
64-bit search:      SOFTWARE\JavaSoft\Java Runtime Environment...
32-bit search:      SOFTWARE\JavaSoft\Java Runtime Environment...
Match:            SOFTWARE\JavaSoft\Java Runtime Environment\1.6
Match:            SOFTWARE\JavaSoft\Java Runtime Environment\1.6.0_22
64-bit search:      SOFTWARE\JavaSoft\Java Development Kit...
32-bit search:      SOFTWARE\JavaSoft\Java Development Kit...
Check launcher:      C:\Program Files\Java\jre6\bin\javaw.exe (OK)
Add classpath:      lib\pde.jar
Add classpath:      lib\core.jar
Add classpath:      lib\jna.jar
Add classpath:      lib\ecj.jar
Add classpath:      lib\RXTXcomm.jar
Launcher:      C:\Program Files\Java\jre6\bin\javaw.exe
Launcher args:      -Xms128m -Xmx128m -classpath "lib;C:\Program Files\Java\jre6\lib\tools.jar;lib\pde.jar;lib\core.jar;lib\jna.jar;lib\ecj.jar;lib\RXTXcomm.jar" processing.app.Base  
Args length:      163/32768 chars

eried

Everything looks fine, can you run older arduino versions?
My website: http://ried.cl

PaulS

Quote
Launcher:      C:\Program Files\Java\jre6\bin\javaw.exe
Launcher args:      -Xms128m -Xmx128m -classpath "lib;C:\Program Files\Java\jre6\lib\tools.jar;lib\pde.jar;lib\core.jar;lib\jna.jar;lib\ecj.jar;l
ib\RXTXcomm.jar" processing.app.Base  

This is running the javaw,exe file from C:\Program Files\Java...

When I run the command, I get:
Quote
Launcher:      C:\Users\pjs9486\Documents\arduino-0022\java\bin\javaw.exe
Launcher args:      -Xms128m -Xmx128m -classpath "lib;C:\Users\pjs9486\Documents\arduino-0022\java\lib\tools.jar;lib\pde.jar;lib\core.jar;lib\jna.jar;lib\ecj.jar;lib\RXTXcomm.jar" processing.app.Base

This is running the javaw.exe supplied with the Arduino IDE.

Try renaming the C:\Program Files\Java folder to something else, and run the command again. Do you then get javaw.exe from the Arduino folder to run?

robert rozee

#11
Jan 09, 2011, 05:09 pm Last Edit: Jan 09, 2011, 05:44 pm by robert_rozee Reason: 1
i deleted the java directory to force the IDE it to run the java installed in 'program files' (someone suggested this earlier on). with the arudino-supplied java there, the behaviour is just the same.

re trying an older version of the IDE, which version would you suggest? i've so far only tried 0021 and 0022, with identical results.

PaulS

I'm suggesting you do it the other way around. Delete (by renaming) C:\Program Files\Java, so that the javaw.exe that the Arduino IDE provides is the one that gets run.

robert rozee

just tried putting back the IDE's java install, and renamed the one in program files as "j_ava". no change, same results  :(

robert rozee

trying to run 0015 fails - the application (arduino.exe) produces an hourglass cursor for 1/2 a second, but absolutely nothing else. HOWEVER, each attempt to launch leaves a process called 'javaw.exe' running, which consumes memory (20mb per copy) and pagefile resources. these processes (one per run attempt) seem to persist until killed with task manager.


Go Up