Go Down

Topic: Opening the "Tools"-menu resets Duemilanove (Read 5014 times) previous topic - next topic

Rasmus Bååth

I found a strange bug in the IDE: Opening the tools-menu resets the board every time.

IDE version: 0022
OS: Ubuntu 10.10
Board: Duemilanove (ATMEGA328)

/Rasmus

mowcius

Well it's due to the auto reset feature (again).

When you open the tools menu, the computer is scanned for serial ports (to make sure they appear on the serial port menu). Due to the way it does this and how the auto-reset on the board works - the board resets.

Not much that can be done apart from disabling auto-reset or just making the serial port submenu do this.

Mowcius

eried

I don't know how do this in Ubuntu, but in Windows I disabled the "serial enumeration" from port properties + my "hacked" rxtxlib (ask the OS for open COM ports and not trying to open each one) = no resets
My website: http://ried.cl

#3
Jan 19, 2011, 12:59 am Last Edit: Jan 19, 2011, 01:06 am by cmroanirgo Reason: 1
I'd like to suggest that this is actually a rather serious bug. I'm using the hardware watchdog system suggested by ArduinoAndy (http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1267907942/0) and whenever I go near the tools menu, OR close the 'Serial Monitor' it causes this reset, which causes pins to pulse...
(It drove me nuts, trying to debug what was going on!!!)

Considering that I'd like to use the arduino as a safety system for an LPG burner, this 'helpful' auto scanning thing has wildly inappropriate consequences! Of course, in the field, I'll have a switch on the PLC to physically isolate the pins from the arduino, but this seems a bit overkill, especially for what appears to be software fault (in the bootloader?).

I suppose a better question is: Is there a way to NOT have the output pins 'dance'....ever? Why does any pin ever pulse? Obviously pins 0 and 1 are used to program via usb, but everything else should remain inert.

2c.

PS: I'm using a diecimila


eried, do you have a link describing what you've done (especially your hacked rxtxlib) to work around this issue?...Thanks.



Coding Badly

Quote
I suppose a better question is: Is there a way to NOT have the output pins 'dance'....ever?

I suggest you start a new topic under Hardware / Troubleshooting so your concerns can be addressed.

pluggy

Its pretty easy to disable the auto-reset, I use a 1-10uF electrolytic capacitor between reset and Gnd.  A 100R resistor between 5V and Reset also works.  You either need to remove the disabling or use the manual reset switch at the right time to upload new sketches.
http://pluggy.is-a-geek.com/index.html

Go Up