Go Down

Topic: X10 Tutorial (Read 4271 times) previous topic - next topic


Error: Sorry, you are not allowed to post messages containing active links to websites or images before you have posted 1 normal messages.

^^ You have got to be kidding me.


The circuit diagram on the X10 tutorial is incorrect.  It does not work at all.


This has been discussed before:


The problems are as follows:

1) The Zero Crossing and Data lines are swapped.
2) The jack orientation is confusing and should be marked with pin numbers.

Here is a suggested replacement:

Also, the only X10 command example shown in the tutorial is the "ALL_LIGHTS_ON" command, which not all modules respond to.  Addressing a single module is not particularly intuitive.  An example of this should be added as well:

// Turns on module A1
myHouse.write(A, UNIT_1, 1);
myHouse.write(A, ON, 1);


Jan 21, 2011, 07:44 pm Last Edit: Jan 21, 2011, 07:51 pm by BroHogan Reason: 1
You are correct - the diagram is both confusing and wrong. In addition:
- if it was correct, it would be so only for the "transmit only" models (TW513/PL513)
- The models that can also receive (PSC05/TW523) use pin 3 for the receive signal.
- The first line of the tutorial says:
This library enables you to send and receive X10 commands

However the lib does not support Receiving - only sending.

Help us improve the Arduino software, examples, website, documentation, etc.

You'd think you found the best place to post your correction.
I hope you have better luck than I did on the severial occasions when I tried.

It seems that good intentions and posting here do not always (seldom?) get the job done. Until there is an active system that can address documentation errors, there will always be frustration for those impacted by the error. This is a pity since it also discourages those that only want to help make things better.

"Data is not information, information is not knowledge, knowledge is not understanding, understanding is not wisdom."
~ Clifford Stoll

Go Up