Pages: [1]   Go Down
Author Topic: [Arduino004] serial error on PBG4 and osx  (Read 858 times)
0 Members and 1 Guest are viewing this topic.
Britanny
Offline Offline
Full Member
***
Karma: 0
Posts: 233
Mais vrai, j'ai trop pleuré, toute lune est atroce
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

hello
on my PBG4 with osx.4.6 (J2SE 5.0, FTDIUSBSerialDriver 2.0.1), i've received error when upload prog to arduino.
RXTX leds bright... i suppose the upload is ok.

Quote
Error inside Serial.<init>()
gnu.io.PortInUseException: Unknown Application
      at gnu.io.CommPortIdentifier.open(CommPortIdentifier.java:354)
      at processing.app.Serial.<init>(Serial.java:127)
      at processing.app.Serial.<init>(Serial.java:72)
      at processing.app.Uploader.uisp(Uploader.java:146)
      at processing.app.Uploader.uploadUsingPreferences(Uploader.java:78)
      at processing.app.Sketch.upload(Sketch.java:1689)
      at processing.app.Sketch.exportApplet(Sketch.java:1749)
      at processing.app.Editor$38.run(Editor.java:1866)
      at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
      at java.awt.EventQueue.dispatchEvent(EventQueue.java:461)
      at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
      at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
      at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:184)
      at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:176)
      at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
Atmel AVR ATmega8 is found.
Uploading: flash
Firmware Version: 1.18
Firmware Version: 1.18

there is no other prog used the serial port as describe in precedent post
i use the setup command and reboot the machine (more exactly shut down and restart as Tom Igoe explain in the processing bug page)

i've tried a simple prog to send string throug serial.
no compilation error, good tranfer, but no blinking TX's led.

 :'(

i was exciting by the new version, but now :-/ :-?

regards

eric
« Last Edit: April 30, 2006, 05:33:04 pm by mrbbp » Logged

Britanny
Offline Offline
Full Member
***
Karma: 0
Posts: 233
Mais vrai, j'ai trop pleuré, toute lune est atroce
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

don't know why, it's work now.
no reboot... :o

eric
Logged

Britanny
Offline Offline
Full Member
***
Karma: 0
Posts: 233
Mais vrai, j'ai trop pleuré, toute lune est atroce
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

well...

serial is a bit "versatil".

- if i boot my computer with the arduino plugged, serial initialize correctly and serial monitor work fine.
if i unplugged the arduino card and plug again, even if i restart IDE, serial monitor doesn't work anymore with this message

Quote
Error inside Serial.<init>()
gnu.io.PortInUseException: Unknown Application
      at gnu.io.CommPortIdentifier.open(CommPortIdentifier.java:354)
      at processing.app.Serial.<init>(Serial.java:127)
      at processing.app.Serial.<init>(Serial.java:63)
      at processing.app.Editor.handleSerial(Editor.java:1397)
      at processing.app.EditorButtons.mousePressed(EditorButtons.java:373)
      at java.awt.Component.processMouseEvent(Component.java:5551)
      at javax.swing.JComponent.processMouseEvent(JComponent.java:3126)
      at java.awt.Component.processEvent(Component.java:5319)
      at java.awt.Container.processEvent(Container.java:2010)
      at java.awt.Component.dispatchEventImpl(Component.java:4021)
      at java.awt.Container.dispatchEventImpl(Container.java:2068)
      at java.awt.Component.dispatchEvent(Component.java:3869)
      at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4256)
      at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3933)
      at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3866)
      at java.awt.Container.dispatchEventImpl(Container.java:2054)
      at java.awt.Window.dispatchEventImpl(Window.java:1774)
      at java.awt.Component.dispatchEvent(Component.java:3869)
      at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
      at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
      at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
      at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:184)
      at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:176)
      at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)

- if i boot without the card plugged, i'm enable to have serial monitor, i've got the mesage above.

 >smiley-sad :-X :-/
it was working fine in arduino003.  :'( snif
it look so simple in v003 and so complex with 004.
sorry i'm on G4 not on Intel smiley-wink

eric
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 9
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hmm, "You may also need to remove the contents of /var/spool/uucp".  So says Processing, anyway.  

Also, can you post the output of typing at the Terminal: groups
And: ls -la /var/lock
And: ls -la /var/spool/uucp
Logged

Britanny
Offline Offline
Full Member
***
Karma: 0
Posts: 233
Mais vrai, j'ai trop pleuré, toute lune est atroce
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

for groups
Code:
mrpow appserveradm uucp appserverusr admin

ls - la /var/lock
Code:
drwxrwxr-x    4 root   uucp   136 May  1 00:34 .
drwxr-xr-x   25 root   wheel  850 May  1 01:25 ..
-r--r--r--    1 mrpow  uucp    11 May  1 00:12 LK.002.009.000
-r--r--r--    1 mrpow  uucp    11 Apr 30 23:55 LK.002.009.002

/var/spool/uucp
Code:
drwxrwxr-x   14 root   uucp   476 May  1 00:35 .
drwxr-xr-x    8 root   wheel  272 Oct 20  2005 ..
-r--r--r--    1 mrpow  uucp    11 May  1 00:35 LK.002.009.010
-r--r--r--    1 mrpow  uucp    11 Apr 30 21:41 LK.002.009.012
-r--r--r--    1 mrpow  uucp    11 Apr 19 12:17 LK.002.009.014
-r--r--r--    1 mrpow  uucp    11 Apr 19 15:38 LK.002.009.016
-r--r--r--    1 mrpow  uucp    11 Apr 19 15:46 LK.002.009.018
-r--r--r--    1 mrpow  uucp    11 Apr 19 16:27 LK.002.009.024
-r--r--r--    1 mrpow  uucp    11 Mar 17 02:56 LK.002.009.026
-r--r--r--    1 mrpow  uucp    11 Apr 19 17:01 LK.002.009.028
-r--r--r--    1 mrpow  uucp    11 Apr 19 18:01 LK.002.009.032
-r--r--r--    1 mrpow  uucp    11 Apr 20 09:53 LK.002.009.036
-r--r--r--    1 mrpow  uucp    11 Apr 20 10:47 LK.002.009.038
-r--r--r--    1 mrpow  uucp    11 Nov 23 01:29 LK.003.009.000

hope this will help

eric
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 9
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

You may need to delete all the files in /var/spool/lock.  From the Terminal, run: open /var/spool/lock
Then select all the files and delete them - you may need to authenticate.
Logged

Britanny
Offline Offline
Full Member
***
Karma: 0
Posts: 233
Mais vrai, j'ai trop pleuré, toute lune est atroce
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

i've deleted all the files in /var/spool/uucp
and it seems to work.

i've no folder /var/spool/lock
in /var/spool/ :
Code:
cups    fax     mqueue  postfix samba   uucp

regards

eric
Logged

Pages: [1]   Go Up
Jump to: