Go Down

Topic: Arduino error on launch (osx intel) (Read 3 times) previous topic - next topic

Gonzillaaa

Hi there I've tried to install arduino on a new machine (intel mac) and get the following error (see pic). Have you ever seen this before? any suggestions on what might be causing it? thank you.

http://www.flickr.com/photos/61113983@N00/121949069/

Massimo Banzi

I knew this was going to happen at some point:) :)

that message means that the library used by arduino to communicate with the board is not compatible with your processor

we will have to recompile the code for mac os x intel but since none of us has such a machine we'll need to put our hands on one first...

aparently rosetta doesn't apply to java native interface


massimo

Gonzillaaa

Hey Massimo I'm not quite the java guru but if you give me precise instructions I can have a go myself. I've got xcode & eclipse running on the machine already...

Thanks.

Massimo Banzi

good this is what I wanted to hear :)))


you need to get the rxtx package from rxtx.org

then you build the library and replace the one that comes with arduino

the java part should work.

now the problem is to see if the gcc compiler will run

but that's chapter 2

massimo

nick

Hi

I can try this as well. The latest version of processing has used the new rxtx and it doesn't seem to be working.

I will try and see what happens over the next week or so.

Cheers

Nick

Go Up