Go Down

Topic: Arduino error on launch (osx intel) (Read 4049 times) previous topic - next topic


Hi there I've tried to install arduino on a new machine (intel mac) and get the following error (see pic). Have you ever seen this before? any suggestions on what might be causing it? thank you.


Massimo Banzi

I knew this was going to happen at some point:) :)

that message means that the library used by arduino to communicate with the board is not compatible with your processor

we will have to recompile the code for mac os x intel but since none of us has such a machine we'll need to put our hands on one first...

aparently rosetta doesn't apply to java native interface



Hey Massimo I'm not quite the java guru but if you give me precise instructions I can have a go myself. I've got xcode & eclipse running on the machine already...


Massimo Banzi

good this is what I wanted to hear :)))

you need to get the rxtx package from rxtx.org

then you build the library and replace the one that comes with arduino

the java part should work.

now the problem is to see if the gcc compiler will run

but that's chapter 2




I can try this as well. The latest version of processing has used the new rxtx and it doesn't seem to be working.

I will try and see what happens over the next week or so.




Hi Massimo I had a go at building rxtx. downloaded done ./configure; make; sudo make install; without problems I copy the new library to the Arduino folder and now the app launches (which is good news :) ) The problem I get now is that I try to run serial_write_basic for instance and get the following error..

Error inside Serial.<init>()
gnu.io.PortInUseException: Unknown Application
     at gnu.io.CommPortIdentifier.open(CommPortIdentifier.java:354)
     at processing.app.Serial.<init>(Serial.java:127)
     at processing.app.Serial.<init>(Serial.java:72)
     at processing.app.Uploader.downloadJava(Uploader.java:130)
     at processing.app.Sketch.upload(Sketch.java:1570)
     at processing.app.Sketch.exportApplet(Sketch.java:1629)
     at processing.app.Editor.handleExport(Editor.java:1724)
     at processing.app.EditorButtons.mouseReleased(EditorButtons.java:343)
     at java.awt.Component.processMouseEvent(Component.java:5166)
     at java.awt.Component.processEvent(Component.java:4963)
     at java.awt.Container.processEvent(Container.java:1613)
     at java.awt.Component.dispatchEventImpl(Component.java:3681)
     at java.awt.Container.dispatchEventImpl(Container.java:1671)
     at java.awt.Component.dispatchEvent(Component.java:3543)
     at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:3527)
     at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3242)
     at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3172)
     at java.awt.Container.dispatchEventImpl(Container.java:1657)
     at java.awt.Window.dispatchEventImpl(Window.java:1606)
     at java.awt.Component.dispatchEvent(Component.java:3543)
     at java.awt.EventQueue.dispatchEvent(EventQueue.java:480)
     at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:234)
     at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:184)
     at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:178)
     at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:170)
     at java.awt.EventDispatchThread.run(EventDispatchThread.java:100)
[VP 1] Device is not responding correctly.

BTW I have also tried with the serial library in prcessing  0111 which claims to be universal binary and it doesn't work either I get the same error.  :-/


This exception means that the serial port is currently used by another application. Make sure that there is only one application accessing the port at once. For example, if you have a terminal program like zTerm or QuickTerm open, make it disconnect from the serial port before trying to open the port in Arduino IDE's Serial Monitor.

Also, make sure that the correct device is selected under "Tools" in Arduino's IDE.

Another question to you as a Mactel owner. Did you try compiling a sketch? I wonder if the avr-gcc toolchain works in Rosetta.


ok I've done a bit more homework. Processing has the same problems with the serial library see here: http://dev.processing.org/bugs/show_bug.cgi?id=315 I'm not entirely sure how to proceed from here if  any of you have suggestions I'd be happy to give it a try.

gck thanks for your suggestions I've checked serial device selected and made sure there where no other apps using the port. Sketches compile fine..



One thing to note is that you should still be able to upload sketches to the board despite that exception.  If the program currently on the board sends or receives serial data, you may need to reset and hit the upload button twice.  I'll try to take a look at the RXTX site and see what the deal is.

Just tried it on my MacBook Pro.

1. Compiling rxtx lib from source made Arduino IDE launch successfully, as reported before.
2. Compiling sketches works.
3. Uploading a program (double counter example) works _occasionally_ after hitting reset button twice.
4. Serial monitor in Arduino IDE does not work.
5. While program is running, on-board RX LED is the only feedback (blinks in intervals of 1000 ms in this example)
6. RX LED _stops_ blinking after approximately 60 seconds (blinking like 53 or 54 times, I even counted)

Any clues? Might #6 be an issue to be discussed elsewhere? I observed this effect on two separate Arduino boards that I have available here (connected to the mactel when trying, not tested on a PC machine yet). The example program itself should loop forever and continue serialWriting, right?


Apr 05, 2006, 11:10 am Last Edit: Apr 05, 2006, 11:18 am by nick Reason: 1
There might be a clue to help us here -



all this may not be necessary if you don't mind using windows XP on your shinny new Intel Mac.....

http://www.apple.com/macosx/bootcamp/    :D

There might be a clue to help us here -


created the var/lock/ directory (being uucp group member), checked for pre-existing /var/spool/uucp/ lock files... didn't help. did you succeed?

meanwhile, I'm having a hard time figuring out the appropriate interval for pressing the reset button twice.

as to that xp bootcamp solution... hmmm... it just doesn't feel right.  :-/
(gonna try it, anyways.)



as to that xp bootcamp solution... hmmm... it just doesn't feel right.  :-/
(gonna try it, anyways.)

tell me about it, i bought a mac for a reason, the reason being its not running windoze.


as to that xp bootcamp solution... hmmm... it just doesn't feel right.  :-/
(gonna try it, anyways.)

tell me about it, i bought a mac for a reason, the reason being its not running windoze.

OK, things get a little off-topic now. I didn't get to try boot camp yet, but others did. Make sure you read the comments on this, too.


Go Up

Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

via Egeo 16
Torino, 10131