Pages: [1]   Go Down
Author Topic: 0005 won't run on OSX PPC  (Read 699 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 17
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

0005 won't run on my PPC Mac Mini:

[JavaAppLauncher Error] CallStaticVoidMethod() threw an exception
Exception in thread "main" java.lang.UnsupportedClassVersionError: processing/app/Base (Unsupported major.minor version 49.0)


My java is:
bento:~ dmd$ java -version
java version "1.5.0_06"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_06-112)
Java HotSpot(TM) Client VM (build 1.5.0_06-64, mixed mode, sharing)


What do I need to do to get Arduino working?
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 12
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

You'll need to run Software Update and upgrade to the latest version of Java.  
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 17
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Software update says "Software Update doesn't have any new software for your computer at this time."

What is the latest version, and how can I get it if Software Update claims I'm already up to date?
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 12
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Uh oh.  You need Java 1.5.  Which version of Mac OS X are you running?
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 17
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Please read my original post, where I showed that I am already running Java 1.5.0_06.

I am running OS X 10.4.7.
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 12
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Sorry for missing the Java version in your first post.

The error you're getting implies that Arduino is somehow running under an older version of Java, even though the one in your path is 1.5.  You can edit the application configuration file that comes with Arduino and set the minimum version to 1.5.  Right-click (Control-click) on the Arduino.app file and select "Show package contents".  Open the Contents folder and edit the Info.plist file.  There's a JVMVersion key; change the String to 1.5+ instead of 1.4+.  Save the file and try to run Arduino again.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 17
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Aha! Thanks very much.
Logged

Pages: [1]   Go Up
Jump to: