Go Down

Topic: arduino on Gentoo AMD64 (Read 1 time) previous topic - next topic

bart

#5
Dec 01, 2006, 12:06 am Last Edit: Dec 01, 2006, 12:36 am by bart Reason: 1
Ok, in the end i reinstalled arduino as you asked me to. It runs ok, no compile errors! I actually copied  /usr/lib/rxtx-2/* and also /usr/share/rxtx-2/lib/RXTXcomm.jar to arduino-0006/build/linux/work/lib/ to make it work.

But it doesn't want to upload to the board:

Code: [Select]
Binary sketch size: 4814 bytes (of a 14336 byte maximum)

-dpart: Invalid name.


HEY! ok, just tried my Atmega8 instead of my Atmega168 (and adjusted the setting accordingly) and with my Atmega8 it uploads.
This actually means that also the installation on my older x86 pc works! (same error with same atmega168)
Kewl!! :)  EDIT: it also worked for the cvs version
Quetsion though: Maybe you have a tip how i can make it work withing a normal user (instead of root) to?
In a normal user the 'serial port' menu is greyed out..
Code: [Select]
Binary sketch size: 4610 bytes (of a 7168 byte maximum)

Error: No such file or directory
-> COM1

mellis

Ah, yes.  The program we use to upload sketches to the board, uisp, is a bit obsolete and the standard release doesn't work with ATmega168s.  The version that comes with the Arduino environment has been patched to work with ATmega168s, but the one you have probably hasn't been.  I'll try to find the patch I applied to the source so you can build a Linux version that supports the 168.

bart

That would be great! Thanks..

mellis

The source package is available here: http://www.arduino.cc/playground/uploads/Linux/uisp-20050207-m168.zip

You'll have to build it yourself, sorry about that.  

bart

Super!  
after i installed i had to mv /usr/local/bin/uisp /usr/bin/
Actually for gentoo users who already emerged uisp, it migth be handier to just first
emerge --unmerge uisp
become root and
unzip uisp-20050207-m168.zip
cd uisp-20050207-m168
./configure
make && make install

One more question:  even though i added my user to the uusp group, if i open arduino as non-root user, i don't get acces tom the serial port. This also counts for PD, so it's not arduino related, but if you have a tip where to search?

Go Up