Pages: [1]   Go Down
Author Topic: Trouble running on amd64 ubuntu  (Read 372 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi, when I run make.sh, I get some warnings, but it compiles.  Then when I run "run.sh", it says
[: 51: ==: unexpected operator

and then yells at me about whether I have jikes installed.  I've installed the latest tarball of jikes (1.22), so that's definitely not it.  Any ideas what I can do to make arduino run properly?
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 11
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

See this thread: http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1163538117/1#1

I just fixed this, so the correct script should be in the Arduino 0007 release.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I added the code you submitted, and now I just get:

[: 52: ==: unexpected operator


Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 11
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hmm.  Your run.sh file should just look like this:


#!/bin/sh

cd work && ./arduino && cd ..


and your work/arduino file should be:


#!/bin/sh

CLASSPATH=java/lib/rt.jar:lib:lib/build:lib/pde.jar:lib/core.jar:lib/antlr.jar:lib/oro.jar:lib/registry.jar:lib/mrj.jar:lib/RXTXcomm.jar
export CLASSPATH

# put the directory where this file lives in the front of the path, because
# that directory also contains jikes, which we will need at runtime.
#
PATH=`pwd`/`dirname $0`:`pwd`/java/bin:${PATH}
export PATH

# put the directory with the native RXTX libs in the library path
LD_LIBRARY_PATH=`pwd`/lib:${LD_LIBRARY_PATH}
export LD_LIBRARY_PATH

java processing.app.Base


I'm not sure where the == would be coming from.  Any idea?
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

After the update to my work/ardino it works like a dream.  Thanks!
Logged

Pages: [1]   Go Up
Jump to: