Pages: [1]   Go Down
Author Topic: Arduino 007 serial monitor problem on PPC Mac  (Read 685 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 30
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello, first post here.  Trying to use a known-good Arduino NG board with 007 on a PPC Mac (10.4.smiley-cool.  Searched forums and some have had similar error but none of the suggestions helped.  Uploading sketches works fine. Opening serial monitor gives error:

Error inside Serial.<init>()
gnu.io.PortInUseException: Unknown Application
   at gnu.io.CommPortIdentifier.open(CommPortIdentifier.java:354)
   etc...


Serial ports shown in IDE are
   /dev/tty.usbserial-a4000q4n [this one selected]
   /dev/cu.usbserial-a4000q4n

like i said, uploading works so obviously port access is ok.  according to forums, this error happens when something else is using port but no other programs are running and i've shut down and restarted.  this machine also has a clean install of tiger on it, btw.  forum posts all suggest re-running macosx_setup.command file but 007 doesn't use that any more, having supposedly fixed the issue that required it right?  i tried downloading 006 and it anyway, which is probably a bad idea, and i got this:

niutil: can't get property users in directory /groups/uucp: No such property
Finished making changes, you should be all set


TIA for any help,

- eric
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 9
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Do you have any other versions of the RXTX library installed (e.g. in /System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Home/lib/ext)?  Do you have a /var/lock or /var/spool/lock directory (you'll have to check using the Go > Folder menu in the Finder or from the Terminal)?  If so, and there's anything in those directories, you might try deleting them.  You could also try creating a uucp group using Netinfo Manager (in Applications > Utilities) and then rerunning the macosx_setup.command.  Do you have any other software that access the serial ports (e.g. other physical computing tools or PDA sync apps or a firewall)?
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 30
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

no other version of rxtx.  no /var directories.  no other software using serial ports.  

but, i after running macosx_setup.command, it works!  so although 007 is supposed to take care of that, apparently sometimes it doesn't?  
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 9
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hmm... maybe it's not as taken care of as I thought.

It worked despite the fact that macosx_setup.command gave you the error message about uucp?  Or did you run it again without an error?
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 30
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

it gives the error every time i run it.  but i believe it worked after first run.
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 9
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Huh, weird.  Glad it's working for you now.  As I said, I don't think you need to run macosx_setup.command with Arduino 0007, but maybe I'll get more reports of people having similar issues.
Logged

Pages: [1]   Go Up
Jump to: