Go Down

Topic: cc1plus error in Arduino 0007 for Windows (Read 853 times) previous topic - next topic

retief

Good day to you all!

I recently got a new Arduino NG board from SparkFun, and I am attempting to get a sketch uploaded to the board from the environment. So far, not much success.

When I try to compile the sketch, I get the following error:
--------------------------------------------------------------------------------
cc1: error: /tools/avr/lib/gcc/avr/4.0.2/include: No medium found

cc1: error: /tools/avr/avr/sys-include: No medium found

cc1: error: /tools/avr/avr/include: No medium found

Couldn't determine program size: /cygdrive/c/Documents and Settings/Jason/Deskto
p/arduino-0007-win/arduino-0007/tools/avr/bin/avr-size: 'C:\DOCUME~1\Jason\LOCAL
S~1\Temp\build47114.tmp\pwm3leds.hex': No such file
----------------------------------------------------------------------------------

When I check the path listed, I find a file called pwm3leds.cpp

It would appear that there is a compiler issue. I checked the paths listed in the cc1 errors, and ther are there except for /tools/avr/avr/sys-include, which does not exist.

I restarted the environment, and I see that I get the following errors upon initial startup:

cc1plus: error: /tools/avr/include/c++/4.0.2: No medium found
cc1plus: error: /tools/avr/include/c++/4.0.2/avr: No medium found
cc1plus: error: /tools/avr/include/c++/4.0.2/backward: No medium found
cc1plus: error: /tools/avr/lib/gcc/avr/4.0.2/include: No medium found
cc1plus: error: /tools/avr/avr/sys-include: No medium found
cc1plus: error: /tools/avr/avr/include: No medium found

/tools/avr/include is empty, and, as previously noted, /tools/avr/avr/sys-include does not exist.

Can anyone give me a little guidance on where to go next in getting through this error?

Thank you,

Jason

mellis

How are you running Arduino?  

Do you have any versions of Cygwin installed on your machine?

What operating system are you using?

Can you set build.verbose to true in your preferences.txt file (in Documents and Settings\Jason\Application Data\Arduino), try again, and post the output?

retief

Good day,

I am running Arduino through the run.bat script included in the zip file, and I have no versions of Cygwin installed on the machine.

I am using Windows XP SP2.

Here is the output after setting build.verbose to true (from first starting Arduino):

Stable Library
=========================================
Native lib Version = RXTX-2.1-7
Java lib Version   = RXTX-2.1-7

cc1plus: error: /tools/avr/include/c++/4.0.2: No medium found
cc1plus: error: /tools/avr/include/c++/4.0.2/avr: No medium found
cc1plus: error: /tools/avr/include/c++/4.0.2/backward: No medium found
cc1plus: error: /tools/avr/lib/gcc/avr/4.0.2/include: No medium found
cc1plus: error: /tools/avr/avr/sys-include: No medium found
cc1plus: error: /tools/avr/avr/include: No medium found



cc1plus: error: /tools/avr/include/c++/4.0.2: No medium found
cc1plus: error: /tools/avr/include/c++/4.0.2/avr: No medium found
cc1plus: error: /tools/avr/include/c++/4.0.2/backward: No medium found
cc1plus: error: /tools/avr/lib/gcc/avr/4.0.2/include: No medium found
cc1plus: error: /tools/avr/avr/sys-include: No medium found
cc1plus: error: /tools/avr/avr/include: No medium found

C:\Documents and Settings\Jason\Desktop\arduino-0007-win\arduino-0007\tools/avr/
bin/
avr-gcc -c -g -Os -IC:\Documents and Settings\Jason\Desktop\arduino-0007-win
\arduino-0007\lib\targets\arduino -w -mmcu=atmega8 -DF_CPU=16000000L C:\Document
s and Settings\Jason\Desktop\arduino-0007-win\arduino-0007\lib\targets\arduino\p
ins_arduino.c -oC:\DOCUME~1\Jason\LOCALS~1\Temp\build6824.tmp\pins_arduino.c.o

cc1: error: /tools/avr/lib/gcc/avr/4.0.2/include: No medium found

cc1: error: /tools/avr/avr/sys-include: No medium found

cc1: error: /tools/avr/avr/include: No medium found

Couldn't determine program size: /cygdrive/c/Documents and Settings/Jason/Deskto
p/arduino-0007-win/arduino-0007/tools/avr/bin/avr-size: 'C:\DOCUME~1\Jason\LOCAL
S~1\Temp\build6824.tmp\pwm3leds.hex': No such file

--------------------------------------------

I noticed the forward slashes in the gcc command above (noted in red). Is that part of the problem?

Jason

retief

A follow-up, as I appear to have fixed the problem.

The problem was with Cygwin, though I never had it installed. I sometimes run the X-Live CD (http://xlivecd.indiana.edu/), and this uses a version of Cygwin. It does not install (does not appear in Add/Remove Programs), but apparently makes registry changes that Arduino doesn't like.

I cleared all registry entries that had to do with Cygwin using a registry cleaner, and once I did that, the Arduino environment starts with no errors and I was able to interface with my board.

I replicated this on another computer to make sure that it was the problem, and my suspicions were confirmed.

Thank you for your help on this.

Jason

mellis

Woah, weird.  Glad you managed to track this down.  I guess there must be cygwin settings related to the path separators (e.g. "\" versus "/"); I hadn't realized that it used the registry at all.  Do you remember which settings you removed?

retief

Here are all of they keys removed:

[HKEY_CURRENT_USER\Software\Cygnus Solutions\Cygwin\mounts v2]

[HKEY_CURRENT_USER\Software\Cygnus Solutions\Cygwin\mounts v2\/]
"native"="F:"
"flags"=dword:00000002

[HKEY_CURRENT_USER\Software\Cygnus Solutions\Cygwin\mounts v2\/tmp]
"native"="C:\\DOCUME~1\\Jason\\LOCALS~1\\Temp"
"flags"=dword:00000002

[HKEY_CURRENT_USER\Software\Cygnus Solutions\Cygwin\mounts v2\/usr/bin]
"native"="F:\\bin"
"flags"=dword:00000002

[HKEY_CURRENT_USER\Software\Cygnus Solutions\Cygwin\mounts v2\/usr/lib]
"native"="F:\\lib"
"flags"=dword:00000002


[HKEY_CURRENT_USER\Software\Cygnus Solutions\Cygwin\Program Options]


[HKEY_CURRENT_USER\Software\Cygnus Solutions\Cygwin]


[HKEY_CURRENT_USER\Software\Cygnus Solutions]


[HKEY_LOCAL_MACHINE\Software\Cygnus Solutions\Cygwin\mounts v2]


[HKEY_LOCAL_MACHINE\Software\Cygnus Solutions\Cygwin\Program Options]


[HKEY_LOCAL_MACHINE\Software\Cygnus Solutions\Cygwin]


[HKEY_LOCAL_MACHINE\Software\Cygnus Solutions]

Go Up