Pages: [1]   Go Down
Author Topic: Arduino 0007, Windows Millennium slowness  (Read 682 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 8
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,
I'm trying to use arduino on Windows Millennium.  The machine is slow, which is the cause of half of all problems.  I'm having trouble with the reset timing.  What state should the board be in when compiling finishes?  Can someone show me a timeline in terms of the events in the needed order so I can try to perfect the timing?

Alternately, can I have arduino precompile (as in compile before) and start sending when I press upload?  If so, what would the timing on this be?

Things which may help: I have successfully uploaded one sketch (by luck on the timing), so it can talk to the board.
I have about a 5-10 second compile time (judging by all the DOS windows which pop up - 15 to 20 of them)

Any help is much appreciated,
Cosis

One more thing I tried:  I set upload to verbose in the prefs file, then copied that command, put it into a batch file, and tried runnign it from there (i had to copy cygwin1.dll or cgywin1.dll to the arduino\tools\avr\bin directory)  still no good on the timing.  Would putting it in a loop which loops until its correct have any effect (i'm fairly skilled at batch files, and could write something like this is I wished)
Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 91
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

This is strange. I have successfully used Arduino on an old 400MHz PC running WinXP (now THAT's slow!) without problems.

> judging by all the DOS windows which pop up - 15 to 20 of them

Something's wrong here. That didn't happen on that old, slow computer. Something else seems to be broken.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 8
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I think the popping up is just a peculiarity of this computer/operating system (its been so long since I used ME heavily that I forget whether this is normal behavior.  Just a bit of this systems past: started Win98, 'soft' (data kept) upgrade to ME.  Used as a family machine for several years.  Relegated to secondary machine.  Multiple OS reinstalls, including one from a formatted hard drive.  So I wouldn't be all to scared if it behaves a bit oddly.
One more thing: these are not 'normal' DOS window - they're DOS 'consoles'.  They have a set size, which one can change via a menu in the upper left.  If maximized, text size changes too.
Again, not sure if this is just a system peculiarity.

I'm guessing your 400MHz had very little else running?  This machine is by no means 'clean'.  Steam and GameSpy have worked their way on there (its a lan party machine) and are running untold amounts of basically... crap (no internet connect on it either, as its the test machine for all types of things, ranging from friend's games to, well, arduino code)

I'm going to go ahead and try to write a looping batch file.

Idea: Bootloader should send an I'm ready signal via serial/usb, then wait for a short time.  This way, arduino on the comp could compile, then say 'reset board to finish upload', and watch for the signal.  Then communication continues as it is now.  This should help eliminate timing issues

Cosis
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 8
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

ok, so I tried loading the program via looping the command used by arduino (as described above), but usip was unable to see it. (apologies, if i've misnamed that, not on the arduino computer now)

So, I'm open to any suggestions.

Thanks in advance,
Cosis
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 12
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

If you're doing things from a command prompt, you can run all the avr-gcc commands first; you only need to press reset before running the uisp command.  Then, type (or paste) in the uisp command, hit the reset button on the board and then press enter at the command prompt.  If the uisp command itself takes a long time to run, I'm afraid you might need to look for another computer to run Arduino on.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 8
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Actually, i dont know if its actually the computer being bad.  I think i may have a dead MAX232.  Since they're pretty cheap, im gonna try to replace it myself (hopefully without damaging my board further....)

Oh, and if this is hard on the arduino board, i should point out i have a modified olimex 28-pin AVR development board (for a class i took)

basically, heres my thought process in deciding the max232 might eb the problem: the avr (mega8) works, runs the bootloader, etc.  While i thought i had a successful upload, im not sure, because its possible i clicked verify instead.

I know what my last successful program was (i uploaded it during the class) - a binary count.  IM pretty sure i emailed the .pde to myself, i just have to find it, then rebuild the circuit and see if it counts.

If it does, im absolutely sure its the chip....  In any case, that would simply be final confirmation
Logged

Pages: [1]   Go Up
Jump to: