Go Down

Topic: "Programmer is not responding" Arduino NG/Win32 (Read 1 time) previous topic - next topic

webograph

#10
Mar 16, 2007, 10:15 am Last Edit: Mar 16, 2007, 11:41 am by webograph Reason: 1
preference set, output is:

Binary sketch size: 1902 bytes (of a 14336 byte maximum)
uisp -v=4 -dpart=atmega168 -dprog=stk500 -dserial=/dev/ttyUSB0 -dspeed=19200 --upload if=/root/sketch_070316a/applet/sketch_070316a.hex

Transmit: { 0 [30]   [20] }
Programmer is not responding.


the scratch is the standard "blinking led" code with the intervals changed.

edit: i'm using 0008 Alpha from svn

mellis

Hmm...  when you reset the board and press the upload button, does the RX light flash before the LED (on pin 13) turns back on?  Does the TX light flash too?  Are you running any other software (firewalls, PDA sync applications, other physical computing tools) that might be using or blocking access to the USB ports?  The ATmega168 is firmly in place?  The board's not resting on anything conductive?

webograph

problem solved, solution unknown (tried it again today, works now).
it was definitely not my timing, although i suspected so for some time.
thanks for your help, sorry i can not give you any solution.
concerning your questions: rx and tx flashed after i pressed "upload"; no other software was running, chip seemed to be in place, no conducting surface.

Barte

I got the same thing.

Just pull out your USB, Put it back in, and upload 1 second after it's recognized.
The sketch will upload and after that the rest button will work again.

bug I suppose.

webograph

for me, it worked exactly the other way round: after booting, it works until i unplug the arduino and re-connect it. guess it has something to do with the way /dev/ttyUSB0 is set up, but i can't figure out what exactly i have to do to make it work again.
(using gentoo linux with custom kernel)

Go Up