Go Down

Topic: Programmer not resp. after assigning pin0 (Read 1 time) previous topic - next topic


Jun 07, 2007, 09:47 pm Last Edit: Jun 07, 2007, 10:54 pm by maartez Reason: 1
Fellow Arduinians,

my Arduino NG worked fine yesterday when i uploading the LedBlink sketch with LedInt set to pin 0 / rx to check out if a transistor was hooked up correctly.

But now it keeps telling me the programmer is not responding. What could be the case?
After an extensive search for several hours i could not figure out what it is.

Actions i have taken.

- changing boud rates.
- checked for right serial port
- changed usb cables, changed usb slots.
- playing with reset button and upload time alot.

But again, at first it was running beautifully. So my basic question is:
       is there a way to go back to factory defaults?

Regards:  Maarten, the enthousiastic newb.


What do you have connected to pins 0/1?  These pins are used for programming and may need to be temporarily disconnected from your circuit during programing.


it was connected it with a buz 10 transistor..   then i noticed that it has to be used for serial traffic, and should be disconnected during transfer. So i did.

my concern is that the pins purpose now has changed ( ? ) and it is blocking traffic.

could this be the problem?


As long as there are no electrical circuits connected to pin 0/1 (with some exceptions) and you press the reset button just prior to uploading a new sketch (within a couple of seconds).  The code of the prior sketch should not effect the uploading of a new sketch.

Given that, I have noticed that occasionally I can not upload a new sketch after some tests.  This has always gone away for me with a power reset on the arduino (disconnect from the computer) although occasionally it has required a restart of the computer as well.


Power resets, different cables, different ports, it all doenst matter..   when i hit Upload, the orange lights  shortly blinks once. and then comes the error.

I cannot image that i a the only one with this problem. There must be someone else assigning pin 0 to something..  if that is the cause.

now can somebody please tell me HOW TO CLEAN IT UP? Reset, Format, Clear, Flash, Delete, Refresh, Start all over again.


If there's nothing connected to pin 0, that shouldn't be the problem.  At least, once you reset the board, the configuration of the pin is reset.  I suppose it's possible you've blown the pin though.  What was connected to it?  

What error do you get when you upload now?


Jun 10, 2007, 11:11 am Last Edit: Jun 10, 2007, 11:12 pm by maartez Reason: 1
Ok, resetter than the reset button isnt possible..

There was a transistor connected to it with 12 volt going through.  
Ive measured that the pin keeps spitting out around 5 volts constantly. So it isnt completely dead either.

i get:

Programmer Not Responding, RESET the board right before exporting.
Programmer is not responding. .

Ive experimented alot with combinations in timing with pressing reset and first it worked fine. so that should not be it..    . .

thx in advance!


Mellis was right...

I consulted my schools technical dude, we exchanged the microcontrollers, and guess what, mine is dead. His is alive,

i fried the microcontroller, however, the rest of the board is still operating properly, so im looking at buying a new chip.
I used an electromagnet in my circuit, and the coil gives a big peak when turned on. his advice was to install a diode over the magnet.

always nasty to learn stuff the hard way,

anyway: Thank you all!



I've always found the hard way to make the best lessons!  :)

When selecting the diode be sure to pick one that can handle 500-1000V (low amperage),  even small inductive loads can send voltage spikes that measure in the hundreds of volts!


Can you post a drawing of what you did?  I'd be curious as to what killed the chip.

Go Up