Pages: [1]   Go Down
Author Topic: Arduino Diecimila, Arduino 0009 and OS X  (Read 382 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 2
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I'm trying to get my Diecimila board communicating with my OS X system and don't seem to be having any luck.

I first tried just loading the usb driver that came with Arduino 0009, rebooting, plugging in the Diecimila and launching Arduino 009. Unfortunately, the usb serial driver wasn't listed under Tools -> Serial Port.

So I looked through the boards and found the posting at http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1143197735, followed the instructions to re-install and still the usb serial driver wasn't listed.

So now I'm stuck. I'm not sure what I need to do in order to debug this and get the board talking with my system. Any suggestions?

Thanks.

- Peter
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 11
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

There is a slightly newer version of the drivers on the FTDI website: http://www.ftdichip.com/Drivers/VCP.htm.  You might try uninstalling the ones that came with Arduino and installing those.

What version of OS X do you have?  Intel or PPC Mac?  In the System Profiler, when the board is connected do you see FT232RL USB UART under USB?  If you open a Terminal and do:

ls /dev/tty.*

What do you see?
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 2
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I've tried the latest FTDI drivers, version 2.2.7 and have the same results.

I'm running on an Intel MacBook Pro w/ 2GB memory, 120GB disk and OS X 10.4.10.

System profiler shows:

FT232R USB UART:

  Version:      6.00
  Bus Power (mA):      500
  Speed:      Up to 12 Mb/sec
  Manufacturer:      FTDI
  Product ID:      0x6001
  Serial Number:      A4001tot
  Vendor ID:      0x0403

And /dev/tty.* shows:

/dev/tty.Bluetooth-Modem        /dev/tty.Bluetooth-PDA-Sync     /dev/tty.Peter-1                /dev/tty.usbserial-A4001tot


As you can see, there's now a tty.usbserial entry under /dev/. This wasn't there last night when I was trying to get the communications working. I'm a bit confused.

But I did just upload the Blink example sketch and its running on the board now. Wahoo!

- Peter
Logged

Pages: [1]   Go Up
Jump to: