Go Down

Topic: Help with Arduino on a Breadboard (Read 2 times) previous topic - next topic

stadham

I tried the settings and it did not work in the Arduino-10 IDE. It still won't load a sketch to the chip.

Maybe I did not burn the mega 8 and 168 correctly? Ponyprog seemed ok with the burn process. I guess my question is what version of bootloader should I burn on to the megas to use them in a standalone Arduino system on a breadboard?

Thanks for any help

stadham

After looking over it seems like a million web pages it seems when i burned the bootloader to my chips i did not set the fuse bytes.

I found these fuse byte settings and they look like they will work with ponyprog

They were found here http://wolfpaulus.com/journal/embedded/arduino3.html

Can some one check them out? Do those look right to someone one who knows these things?

Thanks again for any help



mellis

You can find the fuse settings that the Arduino software uses (w/ the Burn Bootloader menu items) in the hardware/boards.txt file.  Since you're using an external 16 MHz crystal, you should be able to use the settings for the NG, either ATmega8 or ATmega168, accordingly.

stadham

Thanks I will try that tonight after work.

stadham

I am not using a USB connection. I seem to be having trouble opening up my parallel port on my laptop runing XP. I have tried to get Giveio to work (I will look at it more) and have changed the BIOS setting for my parallel port.

It seemed to work once it was trying to write to the mega 168 and I had a mega 8 in the slot using the Arduino IDE. Then I tried again and it stoped working when I tried a second time when I replaced the 8 with the 168.  

If anyone has some advise on this please let me know.

Go Up