Go Down

Topic: New code not running despite flawless flash (Read 1 time) previous topic - next topic

tjdolan

Hi all,
My arduino board has been up and running now for a few weeks and everything has been fine.  Today I tried to interface to a new IC chip, and although the code seemed to flash fine nothing seemed to be working.  After some debugging of both the hardware and software I came to the conclusion that the software isn't getting properly flashed onto the board.  In fact, even if I try to flash some of the example sketches (led_blink) the board continues to run my custom program despite everything appearing to flash fine.

I have taken these steps with no result:
  • reboot computer and arduino board
  • remove and re-install the arduino software on the computer
  • verified that the proper Atmega chip is selected in the menu
  • manually removed all rom, elf, and o files in my code directories


The only thing I can think of that might explain this is that the program flash area of the AVR chip has been worn out (would I get an error message if this happened?).  However, I assume that this is like any other flash and that it will take thounds of cycles for that to occur - I am fairly certain that I have flashed it at most on order of a hundred flashes.

Thanks.  I will very much appreciate any feedback!

Daniel

hi

what do you mean exactly by a "new IC chip"? Everything you say points to selecting the wrong microntroller in the IDE, but since you've checked that, hmmm....
D

tjdolan

By new IC I mean that I just wired up the http://www.arduino.cc/en/Tutorial/ShiftIn shift in register to get some extra inputs.  I discovered this problem while trying to update my code to interface with it properly.  The code wasn't updating...

I am really unsure of how to proceed from here.  I would hate to have to buy a new arduino board, or an avr programmer.  Any other thoughts on what to check?  Is there a way to ensure that the AVR chip selected in the menu is what is actually selected?

Thanks

tjdolan

I just deleted my arduino software directory and the preferences file in the .arudino directory.  After re-downloading the arudino software the problem still exists.  I tried to flash the led_blink sketch, but my custom sketch is still running.  The following shows up in my terminal window when I try to program it with the led_blink sketch.

Code: [Select]
[code]Binary sketch size: 4144 bytes (of a 14336 byte maximum)

Atmel AVR ATmega168 is found.
Uploading: flash
Firmware Version: 1.15
Firmware Version: 1.15
[/code]

After this my custom sketch is still running.

Thanks.

Daniel

#4
Jun 03, 2007, 04:34 am Last Edit: Jun 03, 2007, 04:34 am by Daniel Reason: 1
hey

it really sounds like the wrong processor is selected... I think you have figured it out: the code is not getting uploaded. Not sure why. Worst case, something has happened to the Atmel chip. If you really have to, to can get another from places like NKC Electronics for $5. That might be a good swap test.  

D

Go Up