Go Down

Topic: Uploading error (Read 5696 times) previous topic - next topic


Jan 14, 2008, 12:20 am Last Edit: Jan 14, 2008, 03:58 am by adilson Reason: 1

I'm using WinXP, and an Arduino self made serial board (with subd connector) and Atmega8. If not the same you're using, is similar.
I've used the bootloader with parallel programmer http://www.arduino.cc/en/Hacking/ParallelProgrammer.

With this hardware configuration, when you try to bootload with Arduino 0010, there's a bug that makes you wait more than 10 minutes without messages until complete bootload. Perhaps this is happening with you, that's why you're thinking it's impossible to bootload with Arduino IDE.

If you already has installed Giveio (I'm not sure you'll need, but to be faster than messages, if not installed: http://web.mit.edu/6.115/www/miscfiles/giveio.zip)
and installed XP_Stop_Polling http://www.melabs.com/downloads/XP_stop_polling.reg,

If you know DOS, I suggest you try this:
make a parallel programmer cable (it's easy);
open a DOS prompt window;
go to this directory ...\arduino-0010-win\arduino-0010\hardware\tools\avr\bin

execute this (set highlighted to match your correct directory):
avrdude -C[glow]C:\[/glow]arduino-0010\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -pm8 -cdapa -e -Ulock:w:0xFF:m -Uhfuse:w:0xca:m -Ulfuse:w:0xdf:m -F

and then this:
avrdude -C[glow]C:\[/glow]arduino-0010\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -pm8 -cdapa -e -Uflash:w:[glow]C:\[/glow]arduino-0010\hardware\bootloaders\atmega8\ATmegaBOOT.hex:i -Ulock:w:0xCF:m -F

Remove the cable, and press reset. If led on pin13 blinks once and fast, then open Arduino 0010 and try to upload some sketch (blink example, for example).

Or, if you think it's too complicated or not familiarized with DOS, try this:

Download Arduino 0007 http://www.arduino.cc/files/arduino-0007-win.zip
Run Arduino.exe or Run.bat;
Chosse correct IC and board;
Choose Comm Port;
Burn Bootloader with Parallel Port Programmer.

Good luck. And don't give up. You just had a bad day.


The programmer is not in the IDE, it is a dev. tool for 5 kinds of ATmegas, one of them is ATmega 8, so have to use PonnyProg, i burned a few without problems, still did not touch the fuses. I used this without problems in the past, i just need the right fuses. Thanks for help! I tried to revive the dead ATmega 8 and the another dead ATmega 48, i used the extern oscillator way, it did not help...I have a collection of CMOS-oscillators, useless...Thanks for help!


And now to Adilson Akashi, thanks for the help too! I think i need some time to build the parallel programer , i must buy the connector first; what i tried it was another icp programmer where a 244 is built into the sub-d connector, no result.


I took the second (good) ATmega 8 and using these intsructions for a 16 MHz X-tal:
i made a hoes for SUT0 and the rest i letted free. The result:
PonyProg said "write failed", i thought "this is really bad...", BUT it was possible to erase, after erasing i wrote again with all fuse-fields free.
And now the surprise: back to the Arduino the LED blinks only one time! So, i thought i was lucky maybe, but i get the same error now...I become crazy.


Sorry. I posted all this because I thought it never worked before.


Using this link:
and the AVR Fuse Calculator i burned again the bootloader, the LED blinks one time, so the bootloader is burned, i am getting always the same error message, trying to upload the blink-file.


OK, i think this link was ok, IT WORKS AND I AM HAPPY!!!!!!!!
Let us think about it, i have the bootloader and using Arduino 010 works, trying with Arduino 002 and 009 it did not work, i still got the same error-message as before.
What is the difference between these programms?
But thanks for help! So, the right fuse-bits and the right software now...

As an ideea, i find this forum very usefull, maybe it is somebady with experience there who is prepared to explain us something about the fuse-bits, i think this is very important and i wish to learn something about it, maybe i am not alone with my desire...

A good link would make the job too.


I just want to describe shortly how it was with PonyProg, maybe someboday has the same troubles:

1. step: with the right fuses click on "write programm", no error, after that i employed the chip on Arduino, it blinked 8 times, no upload possible

2. step: back to PonyProg, click on "erase", with the same fuses click on "write all", after that a message appears, "write failed".

3. step: click on "erase", click on "write programm" (like first time), no error

4. step: back to Arduino, it blinks one tiem, bootloader ok

I am sorry, but i have no explanation for that strange behaviour, if somebody knows why, please let me know, i really don't understand what happens...

Go Up