Go Down

Topic: Mac OSX (10.4.11) and Diecimila connection help (Read 7910 times) previous topic - next topic


Does it matter if you have the Arduino board plugged in or not when you start the Arduino software?

What's the ZEROGRAVITY device?  I wonder if somehow it's confusing the serial library we use (RXTX).

One potential workaround is to edit your Arduino preferences file (/Users/<USERNAME>/Library/Arduino/preferences.txt) and set serial.port to /dev/tty.usbserial-A4001t5b.  (Edit the file when Arduino isn't running.)  


Ok, I edited the preferences file as you suggested, no luck.  It says:

java.lang.NoClassDefFoundError: javax/comm/CommDriver thrown while loading gnu.io.RXTXCommDriver
processing.app.SerialException: Serial port '/dev/tty.usbserial-A4001t5b' not found.  Did you select the right one from the Tools > Serial Port menu?

The Serial Port menu is still grey.

The ZEROGRAVITY device was a bluetooth headset, I deleted it and it does not show up when I ls /dev/tty anymore, but still no help.  I have restarted, done everything with the Arduino software off, etc...  

Thanks again for helping to work through this!


Weird.  Can you try this, I want to make sure that there aren't any weird non-printing characters in the name of the USB device:

ls /dev/tty.usb* | hexdump -C

and post the output?


Ok, I turned off bluetooth completely, so the connected Arduino is the only port.  Here is what I got for the hex dump...

00000000  2f 64 65 76 2f 74 74 79  2e 75 73 62 73 65 72 69  |/dev/tty.usbseri|
00000010  61 6c 2d 41 34 30 30 31  74 35 62 0a              |al-A4001t5b.|

I have checked the serial.port= value in the preferences, and tried it with and without the "." at the end.

Throughout all of this, the Tools > Serial Port menu remains greyed out.



Is there another computer you can try uploading from, temporarily, just to see if the board works at all?

The last period isn't part of the name of the serial port, btw, it's the character that hexdump uses to represent non-printing characters, which in this case was the newline that ls outputs.


Yes, I actually did that this morning... works fine on my intel iMac - just wanted it in the macbook I can move out to my garage (where all my electronics stuff is).  No big problem!

Thanks for looking into it for me.


Strange.  What if you upload the ASCII Table example using the other iMac, then connect the board to the MacBook.  Then run (from the Terminal): screen /dev/tty.usb* 9600


Just an update.....I STILL get this message when I start the IDE.

java.lang.NoClassDefFoundError: javax/comm/CommDriver thrown while loading gnu.io.RXTXCommDriver

I have tried everything, I have used all 3, yes 3 of my Mac's and they all get the same error.

The tools>serial port is STILL greyed out and I can not select anything.

I have tried EVERYTHING, I have researched EVERYTHING....oh, and I am not all that stupid.

It works flawlessly on any PC I have tried (currently 3 different ones)

Anyone else have any ideas, I would greatly appreciate it. The reason I want it to run on my mac's is I have Flash installed on them (not my PC's) and my project requires Flash communications.


In the terminal I still get:

tcsh: /dev/tty.usbserial-A4001qyc: Permission denied.

When I type in :

/dev/tty.usb* 9600


And finally here is my HEX dump:

00000000  2f 64 65 76 2f 74 74 79  2e 75 73 62 73 65 72 69  |/dev/tty.usbseri|
00000010  61 6c 2d 41 34 30 30 31  71 79 63 0a              |al-A4001qyc.|


Hmm, try uploading the ASCII Table sketch from one of the PC's.  Then on the Mac, in the Terminal, run:

screen /dev/tty.usb* 9600

Do you see the table being printed?

BTW, to exit screen, you type Ctrl-a followed by k.  


YES! The table is printing....WOW. It MUST be a step in the right direction.

I have no problem in the PC environment, and still no luck on the Mac.

What do you think I should do next?


I have tried COM1, COM2, COM3 , by changing the preferences file. The tools>serial port menu is sill grayed out and I get the following response:

java.lang.NoClassDefFoundError: javax/comm/CommDriver thrown while loading gnu.io.RXTXCommDriver
processing.app.SerialException: Serial port 'COM3' not found.  Did you select the right one from the Tools > Serial Port menu?
     at processing.app.Serial.<init>(Serial.java:149)
     at processing.app.Serial.<init>(Serial.java:63)
     at processing.app.Editor.handleSerial(Editor.java:1485)
     at processing.app.EditorButtons.mousePressed(EditorButtons.java:373)
     at java.awt.Component.processMouseEvent(Component.java:5580)
     at javax.swing.JComponent.processMouseEvent(JComponent.java:3135)
     at java.awt.Component.processEvent(Component.java:5348)
     at java.awt.Container.processEvent(Container.java:2010)
     at java.awt.Component.dispatchEventImpl(Component.java:4050)
     at java.awt.Container.dispatchEventImpl(Container.java:2068)
     at java.awt.Component.dispatchEvent(Component.java:3885)
     at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4256)
     at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3933)
     at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3866)
     at java.awt.Container.dispatchEventImpl(Container.java:2054)
     at java.awt.Window.dispatchEventImpl(Window.java:1791)
     at java.awt.Component.dispatchEvent(Component.java:3885)
     at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
     at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
     at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
     at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:184)
     at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:176)
     at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)


I noticed that the Arduino runs the ASCII table 1 time then ends. If I open another shell and type in "screen /dev/tty.usb* 9600" I get "

Sorry, could not find a PTY."

Then I unplug the Arduino (pressing reset does not do anything) and plug it back....it works again? (printing the table, not in the IDE)

I tried unplugging then plugging back in, then immediately run the IDE to see if it would connect....no luck.


It seems like the problem is with RXTX (the serial library for Java that we're using in the Arduino environment), since it seems like the board and USB communication is working fine w/ screen.  My guess is that you have a version of Sun's serial library or another version of RXTX somewhere that's conflicting with the Arduino version of RXTX.  What's in: /System/Library/Frameworks/JavaVM.framework/Home/lib/ext ?

Go Up