Pages: [1]   Go Down
Author Topic: uploading problem for arduino bluetooth  (Read 1044 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 9
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello. I just got my arduino bluetooth.. i'm pretty new to all this so my question might be a little absurd...  smiley-wink
the thing is that right after the bootloader is finished i loose BT connection with my machine... i can't even upload the blink example wich is supposed to be a very simple sketch
I've played a little with the usb arduino and i never had any problems..
hope somebody knows whats going on with my board!
thanks!
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 11
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I'm not sure I can help, but with a little more information someone else might be able to give you some pointers.  What operating system are you using?  What steps do you follow when you try to upload?  What happens?
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 9
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

hello! first of all thanks for the super fast reply!
i'm working under windows xp. When i try to upload a sketch (i press reset button on board, then the upload button on arduino software..) for a while the arduino software seems to be thinking but for some reason after a few seconds bt connection on the pc disconnects... smiley-sad then of course the sketch can't upload correctly because it doesn't find de com port (in my case COM40)..
any idea?
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 11
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hmm, can you reassign the bluetooth connection to a lower port number?  I know Arduino sometimes has problems with anything in the double-digits, though I'm not sure that's the only issue here.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 37
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

hey there!

i'm having the same problem - due to my brandnew avrisp i can
program the board anyways, but i'd like to use the arduinosoft-
ware for debugging...

hope i'm using the right bootloader, which i found here:
http://svn.berlios.de/viewcvs/arduino/trunk/bootloaderBT/ATmegaBOOT_168.hex?view=markup

thanks & bye bye,
hans
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 1
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I am having the same problem.
I am using Sony notebook and bluetooth manager.
Port is set to COM40.
Does this thread give any solution?
Cheers,
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 4
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Same problem here. Toshiba Bluetooth Manager on XP disconnects when I reset the arduino, preventing the IDE to upload the software.

Is there eg any commands to be tested in the IDE to at least see if the communication works properly (it says 'ciao' all the time, but that's just one way until the reset button is pushed - not sure if this stops because 1) it looses connection or 2) it turns into reset mode for a few secs).

Any solution is much appreciated!
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 1
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have the same problems !

My Arduino BT didn't communicate to my pc ( Windows XP with toshiba BT manager or Ubuntu 8.04, last beta stable).
I can't upload anything. On windows I've tried differents ports (Com 1, 2 , 6 ,7 , 40, 41 ), the Toshiba BT manager seems to connect ( I saw an icon ) but during the transfer it disconnects ...  I pressed the reset button on the board before to send, but it is still failing. BT is paired with pc, I can send files between them.
I've tryid arduino-0010, arduino-0009, arduino-0008, arduino-0007!!!

On GNU/Linux, ubuntu 8.04, the arduino-0010 IDE can't see any SERIAL PORT. ArduinoBT is paired with the computer, and working because I cand send information between them.

I cant see any bluetooth port on /dev/tty* . Can I configure it myself manually??
Is it possible to use avrdude (rfcomm channel...) in a terminal window?

I spend several day trying to upload a sketch, and nothing. I am thinking to return the 2 Arduino BT that I bought.

My pc is working properly, i can program Arduino Diecimila using usb cable --> perfect. ( on Win XP and Ubuntu ).

PLEASE HELP ME, may be it is easy to solve it.

thanks,

Guillem
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 1
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

The problem is solved ! but Arduino Staff should improve this bug in Arduino IDE.

see in hardware section:

http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1180879548

cheers

Guillem smiley-grin
Logged

Pages: [1]   Go Up
Jump to: