Pages: [1]   Go Down
Author Topic: Export button resets PC  (Read 697 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Full Member
***
Karma: 0
Posts: 134
panta rei resist the resistors!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello,
did anyone have this problem before?

My Arduino 2.0 usb was working great and now
by simply clicking the export button it RESTARTS my pc.

any simple program just reebots the pc
(after having compiled beautifully).

I've done all I could think of, even delete and recreate the arduino-0002 folder.

UPDATE:
I've tested the board with another pc and it works great.
Can somebody tell me what's going on under the hood when you press the "export button"?
the pc reboots at the first click of the button! It might be conflicting with somenthing that I don't know?


any ideas?
thanks in advance
beltran
« Last Edit: December 11, 2005, 02:00:14 pm by beltran » Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 11
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

That's really weird.  Are you sure you're using the right serial port (com port)?

The export button simply recompiles your code and runs uisp, a program to upload the code to the board.  I don't know why either would make your machine reboot.  What's in the file called "stdout.txt" in your Arduino application directory?

Are you running any other programs that use the serial ports, com ports, or USB ports (like a PDA sync application or a vigorous virus checker)?

Have you installed cygwin on your machine?
Logged

0
Offline Offline
Full Member
***
Karma: 0
Posts: 134
panta rei resist the resistors!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

hey david,

to answer to your questions:
- stdout.txt is empty

Quote
Are you running any other programs that use the serial ports?

I'm not sure but I don't thinks so, because the problem started appearing after a while: I had safely exported a few times before the problem happened. at the beginning I thought the problem was in the code I was uploading into arduino, I thought I found some sort of fork bomb that crashed my computer. But then I tryed to do a simple hello world or led blinking and it crashed as well.

I tryed to reinstall the arduino-00002 folder from scratch but that didn't work either, the pc keeps rebooting. It seems as it set some nasty global variable or somenthing else that tells it to reboot  ??? ???

Quote
Have you installed cygwin on your machine?

cygwin1.dll is inside the arduino program folder arduino-00002... I haven't done anything else with it.
searching on my pc there are other cygwin1.dll under several versions of the old ide and wiring folder as well...
there is only another one cygwincompiler.py (python) under open office but I don't think It has anything to do with it smiley

any other idea?
what is cygwin all about it?

Quote
 The export button simply recompiles your code and runs uisp

does this means that we can avoid clicking on the compile button? that the export button does it automatically?

thanks for the help
b.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 35
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

i know my computer often freezes or reboots when loading to the arduino and it has to do with the computer having flakey usb. it will do the same thing reading memory cards, or uploading to my ipod. maybe you could try a pci usb card.
« Last Edit: March 17, 2008, 02:02:31 pm by unsped » Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 27
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

i am using the arduino mini and have it connected to my mac laptop. i have a processing script analyzing serial data that streams in from the arduino.
once in a while my mac automatically restarts with me doing anything.  the processing script has been running for at least 5 min, i have not press any buttons ... ?

does anyone know why that happens?

maybe one of the processing libraries causes that or the arduino sending strange data over the usb port.

stephan.
Logged

USA
Offline Offline
Jr. Member
**
Karma: 0
Posts: 73
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

stephanschulz,

You may have answered this already but, what OS are you running?
Logged


0
Offline Offline
Newbie
*
Karma: 0
Posts: 27
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

i am running osx on a mac book pro.
i also found this discussion on the apple forum
http://discussions.apple.com/thread.jspa?messageID=6859932&#6859932

other people have the same problem, and the problem seems not to be connected to using any usb device.
so it is not arduino's fault.

cheers.
Logged

USA
Offline Offline
Jr. Member
**
Karma: 0
Posts: 73
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Has there ever been any issues reported with the FTDI FT232R driver?

I know on windows that you get lockups that can be annoying sometimes but I think that's related more to AVRdude.exe
Logged


Pages: [1]   Go Up
Jump to: