Pages: [1]   Go Down
Author Topic: Test sketch not uploading on different computer  (Read 686 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 5
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have been successfully learning to use an Aruduino diecimila on a borrowed Window XP laptop.

Needing to return it, I have been trying to get the same board to work on my desktop.
I downloaded the program, plugged in the board, and tried running the "blink program" to test that all was working.  
I get the following message: Problem uploading to board. See www.arduino..../troubleshooting#upload for help.
Below that is:
avrdude: stk500_getsync(): not in sync: resp=0x0
avrdud: stk500_disable(): proocol error, expect=0x14, resp=0x51

Can someone please explain this.

Note:  I did everything I could think of fromt he troublesooting guide under upload.
The green light is on.  I plugged in an LED in digital 13 and it blinked once etc.
Also under "tools" the serial port is listed as COM1 (but on the laptop along list of COM ports were shown and I had to find the right on.  here I am only given the one).

System:
I have a custombuilt, Pentium 4, with OS Windows XP professional

Thanks.
Logged

0
Offline Offline
Sr. Member
****
Karma: 0
Posts: 375
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Did you install the ftdi drivers?
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 5
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I tried but not sure I was successful.

There is a folder in the program files entitled "FTDI SUB Drivers"
and under that there are 17 files including 5 in the form *.dll
I figured that covered it.  Maybe not.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 5
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I went to the FTDI site and reinstalled the drivers.

Running the blink test still gave me the same message.
Logged

0
Offline Offline
God Member
*****
Karma: 0
Posts: 572
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

It's most likely the timing of the reset.

Depending on the speed of your computer, you have to push the reset button on the arduino at different times.

On my old PII 300MHz laptop, I have to push the reset button about 3 seconds AFTER I push the upload button in the IDE.

On my 2400MHz desktop, I push the reset and upload buttons simultaneously.

When you push the reset button, the bootloader waits (depending on which version of the bootloader you are running) 3 seconds for a new sketch to be uploaded. If it doesn't get anything within those 3 seconds, it starts to run the last uploaded program which is still in it's memory.

When you push the upload button, the IDE compiles you program, and starts the upload. This process is so slow on my old laptop, it misses the 3 second "window" if I don't time my reset button push just right, and I get the "not in sync" error you are seeing.

Of course I just realised that you have a Decimila, which has the auto reset feature yeah? I always forget about that, I only have the original USB board (pre-NG even!).

It still may be a timing issue. Alternatively, triple check the right Board and serial port are selected in the "Tools" menu. I see that error when I build for an Arduino with a different clock speed, eg. lilypad.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 5
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks.......though the decimila doesn't need a manual reset, it's useful to learn about other situations.  My desktop is way faster than the laptop as well.

I am closer though.  I am clearly having problems with the correct assignment  between the Arduino and the appropriate COM port.  The tools tab only shows one available COM port and that one isn't any of the 8 USB ports I have on this computer.
So I am working through the device manager to find where the USB ports are listed and trying to get these to appear on the tools tab of the arduino so I can assign it correctly.

I am working with someone else on this as well; so understand if no one replies to this string at this point.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 5
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Problem solved!
Logged

Pages: [1]   Go Up
Jump to: