Go Down

Topic: SOLVED: Arduino UNO WiFi connection problem (Read 583 times) previous topic - next topic


Apr 27, 2017, 08:08 am Last Edit: Apr 27, 2017, 08:39 am by marmorkatten

So I bought an Arduino UNO WiFi yesterday to use it in my greenhouse project. Everything was working fine the first time I set it up using this guide


But then I discovered the firmware had to be updated to ESP8266 (0.0.3) to get the Ciao library or more specific the <UnoWiFiDevEd.h> library that replaces the Ciao library for the Arduino UNO Wifi board.

Now to the problem. When I plug in my board to my Mac using USB, the board shows in my Available Networks list and I can select it as a network. But when I try to go to the adress (mentioned in the guide linked above) to configure the board it only works sometimes, roughly one of ten times. And when the website loads I can't get past the "start page" to connect it to my wifi, it freezes when I try to change the host name i.e.

For additional information:
- I have already tried re-updating the firmware
- Rebooted my own WiFi several times and connected to the board when my own WiFi was off

I would really appreciate the help, I have a school project that I would like this to work with.

EDIT: I think the problem was that my iPhone connected to the board automatically for some reason, and did this before I could have a chance to connect with my computer. But had no problem configuring board from iPhone so, problem solved.

I'll leave this here if someone happens to run into the same problem.

Go Up