Go Down

Topic: Arduino IDE window (Read 403 times) previous topic - next topic

chilinski

I'm new. I run Gutsy Gibbon on an Asus EEEPC 701. At work, I attach the EEE to a monitor. When I run the IDE at work on this monitor (with a 1024x768 resolution), everything is fine. When I take my E home, I don't have a secondary monitor. When I run the IDE there (on it's 800x400), only the code window appears. You cannot see the status window or the serial monitor. You can't scroll down to them. The bottom portions are simply not there; they are NOT below the bottom of the screen. Again, they are not there. You also cannot do the EEE "trick" of holding down a special key and dragging a window so parts of it go offscreen (If you have an E, you know what I mean).

You can duplicate this on a 1024x768 by grabbing the bottom of the window and gradually dragging it up to adjust the screen height. At some point, the status window will disappear. There is no way to get it to reappear without resizing the window.

Does anyone have any suggestions to remedy or work around this?

Mike Mc

Sounds like it is defaulting to the same screen size it was set at previously. It would be better if it defaulted to the standard size or there was a setting in the options pane to turn that on or off.

wayoda

Hi,
I run a patched version of the arduino-0010 IDE on my eeepc 701 running the Xandros easymode OS.
see this thread
http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1200721730
for some basic info and download-links.

I didn't felt like updating the pacht to arduino-0012 yet.

(Mostly because a one-line patch I send to the developers mailing list a year ago, that already solves the basic window-size problem, never made it into the sourcecode without any comment)

But if you are really desparate I consider an upgrade...

Eberhard





chilinski

It would be nice to have it work correctly on the E, but I'm certainly not desperate. If you get around to it, please let me know.

Before you patched the source, did you look at the preferences file in your /home/%username%/.arduino/preferences.txt file?

chilinski

Well, I got some time finally to play around with the preferences.txt file that is located in the .arduino directory in your home folder.

I changed default.window.height from 600 to 300 and last.divider.location from 320 to around 220, and now it works just fine.

However, this was AFTER I resized the entire window, so this may have had something to do with it.

There are tons of configuration things in the preferences.txt file.

Go Up