Pages: [1]   Go Down
Author Topic: 012 refuses to compile  (Read 430 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Sr. Member
****
Karma: 0
Posts: 267
dinosaur cork
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Trying to install 012 on a Mac and get this

java.io.IOException: Target platform: "null" not found.
Make sure that "build.target" in the
preferences file points to a subdirectory of
/Applications/DevelopmentApps/arduino-0012/hardware/cores
... long string of java errors





There seems to be no "build.target" in my preferences file. I also tried deleting the old prefs file and restarting Arduino to insure that it built a new one.

Any ideas?
« Last Edit: October 17, 2008, 11:00:44 am by paulb » Logged

0
Offline Offline
Sr. Member
****
Karma: 0
Posts: 267
dinosaur cork
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I solved this by choosing Diecimila from the "Board" menu, quitting and restarting.

Sounds like there's no default setup for reading boards.txt but this is just a guess.

Paul B
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 9
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

The boards.txt file is (currently) stored with the Arduino application, so changes aren't automatically carried over between versions.  If you've modified your boards.txt file to include new boards and selected one of them, you'll get that error when you try to run a different version of Arduino.  I'll probably move the boards.txt file to your home directory at some point, but I wanted to take a few versions to let its format stabilize first.
Logged

Pages: [1]   Go Up
Jump to: