Go Down

Topic: C++ Arduino development in eclipse on the mac (Read 427 times) previous topic - next topic

maspen

Dear Friends,

I've been 'stuck' trying to get my development environment up and running. Specifically, I want to write C++ in eclipse and am using a mac (macbook pro running 10.4). I have read/tried the eclipse + plugin, but the problem is that it requires a .xml file which (supposedly) is part of AVR Studio; which, as you know, is a Windows application.

I tried the vm-ware path (installing Windows on my mac, eclipse, plugin etc.) but could not get Windows to install as a vm-ware image.

So, I'm reaching out to you to  kindly either (a) point me to a tutorial or (b) explain to me how I can get to where I want to go.

Many thanks in advance.
--MA

westfw

Not sure what this has to do with arduino, but have you tried extracting the needed xml file from the windows install (or A windows install?)  How far do you get with AVRStudio?  Does it not install, or just not run?  (I've had some luck with things like CodeWarrior and IAR IDEs in WINE, where they install ok, but won't run; it should still be easy to extact XML files from such a non-working install...

Or; tell use which .xml file you're missing...

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy