Go Down

Topic: Problems with Arduino (Read 1 time) previous topic - next topic



Recently i built the Arduino single-sided serial board(version 3).
I'm using Atmega8 microcontroller.
I downloaded the latest Arduino software for Windows.
I succesfully loaded the bootloader for atmega8 using a isp programmer and ponyprog.
Now the led from pin 13 lights up 8 times.
I start up the Arduino application,i compile the blink program,i choose from Tools-Board-Arduino Diecimila.
I press the upload button.
The led from pin 13 starts to light up.
The RX led lights up 3 times.
And i receive this error in Arduino application:

Binary sketch size: 1124 bytes (of a 14336 byte maximum)

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

I changed the board to Arduino NG or older w/ Atmega8 and i get the same error.
I don't know what i forgot to do,i'm in a hurry now and i do not got much time to study the problem.
Can you guys help me out ?
I appreciate,thanks !


Nov 07, 2008, 03:02 pm Last Edit: Nov 07, 2008, 03:04 pm by adilson Reason: 1
Did you set the jumpers correctly?
Auto Reset jumper installed;
and serial enabled jumper in correct position?

Did you try uploading pressing the reset button? right before (or right after or seconds after) you press the upload button?

Did you try to upload sketches, without the bootloader, using your ISP Programmer?



Thanks for your reply.
Auto reset jumper is installed,serial enable jumper is in correct position(2-3).
I tried to upload by pressing the reset button right before(after)i pressed the upload button but i get the same error.
I tried with the ISP programmer too but no luck.
I think it's a software problem because i checked the hardware many times and i found no problems.



Simple solution!

You've chosen the wrong board in the menu. you need to choose "Arduino NG or older with AtMega8"

By choosing "Decimilia" it assumes auto-reset and AtMega168

Go Up