Go Down

Topic: The Dreaded upload error of DOOM! (Read 2141 times) previous topic - next topic


I am a newbie to the Arduino world.

I got my board (the Duemilanove that auto selects between USB and external power source) and got it connected with no issues. I uploaded the first program in the Tutorials section (Blink), it worked great. I opened up the second program (Blink with out delay) hit upload and got the dreaded upload error (details of error to follow).

I have checked, checked again, and checked for a third time the board, USB con. USB cable, USB port and finally the settings for the USB to serial adapter port in device manager. I have tried different USB ports, cables, drivers, but no matter what I do I seem to be unable to upload software to the board. I've tried the "Set RST on close" setting with no luck. I've tried re-seating the main chip. I have also gone over the uploading troubleshooting guide on the arduino site.

Everything that I have said above has been tried on a second computer with the same exact results. and yes, I have tried the bit with depressing the reset button before clicking upload and every conceivable iteration of button pressing in different orders and delays. I have checked that I am using the correct port for uploading as well.

One thing that I think is strange is that the board usually executes the code immediately on power on, but not always. When ii doesn't start it instantly, it does all of these random flashes with the on board LED, THEN starts the code.

When I tell the Arduino Environment to upload software, I can see that the RX light flashes three times, VERY briefly, then the software gives me the following...

avrdude: Version 5.4-arduino, compiled on Oct 11 2007 at 19:12:32
       Copyright (c) 2000-2005 Brian Dean,

       System wide configuration file is "C:\Documents and Settings\Mitch\Desktop\arduino-0012\hardware/tools/avr/etc/avrdude.conf"

       Using Port            : \\.\COM3
       Using Programmer      : stk500v1
       Overriding Baud Rate  : 19200
avrdude: ser_open(): setting dtr
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: Send: Q [51]   [20]
avrdude: Recv:
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

avrdude done.  Thank you.

I am starting to believe that somehow the board has failed me, but any advice would be greatly appreciated!

Thanks in advance!



Have you got a programmer? If so, just re-burn the bootloader and I'll bet you'll be fine. You could also use some of the "self program" techniques described on the forum if you don't have one.

Go Up