Pages: [1]   Go Down
Author Topic: Trouble with a Sanguino  (Read 822 times)
0 Members and 1 Guest are viewing this topic.
Space Coast Area, Florida
Offline Offline
Newbie
*
Karma: 0
Posts: 48
Flickershow Media
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I'm having some trouble operating my sanguino. I've folowed all the steps on their website to a T, but to no avail.

My error messages arise when I upload to the board.
avrdude: stk500_getsync(): not in sync: resp=0x30
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51


Does anybody know what I can do to fix this?
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 9
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I'd recommend asking Zach for advice: http://sanguino.cc/contact.  
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 12
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I got this message when I picked the wrong COM port in the Arduino software.
Logged

Space Coast Area, Florida
Offline Offline
Newbie
*
Karma: 0
Posts: 48
Flickershow Media
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

By now, it's no longer giving me the message every time I upload. It allows me to upload after a reboot, but only the first time I upload. After I do it once, I need to reboot my system to upload again.
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 9
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Have you tried disconnecting and reconnecting the sanguino instead of rebooting?
Logged

Space Coast Area, Florida
Offline Offline
Newbie
*
Karma: 0
Posts: 48
Flickershow Media
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

"Have you tried disconnecting and reconnecting the sanguino instead of rebooting?" Yes. Yes I have.

Anybody else having this same problem?
Logged

Space Coast Area, Florida
Offline Offline
Newbie
*
Karma: 0
Posts: 48
Flickershow Media
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Now I'm getting the same problem with my arduino. Please help if you know anything.
Logged

0
Offline Offline
Sr. Member
****
Karma: 0
Posts: 375
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Providing information about your computer/operating system would make it easier for people to help you.
Logged

Space Coast Area, Florida
Offline Offline
Newbie
*
Karma: 0
Posts: 48
Flickershow Media
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Im running Windows XP on a laptop. I've got an Arduino Diecimilla and the Sanguino v1
Logged

London
Offline Offline
Faraday Member
**
Karma: 8
Posts: 6240
Have fun!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Did you try all the relevant suggestions here: http://www.arduino.cc/en/Guide/Troubleshooting#toc2
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 9
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have found that the simplest solution to this situation is to compile the sketch, place the cursor on upload, press the reset button, press the enter key to start the upload, press the reset key again.  It has worked 100% of the time for me and I have tested it on 42K+ sketches.  There is a visual indicator that the sketch is uploading, the debug (red) LED will oscillate.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 11
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

It is quite possible your ftdi chip is really causing the issue.  Here follow this tutorial http://ladyada.net/make/fuzebox/programprep.html scroll down until you see "Hacking the cable part 1"  this will show you how to configure your ftdi chip on your arduino and in your ftdi usb programming cable.
Logged

Pages: [1]   Go Up
Jump to: