Go Down

Topic: Can't upload sketch from 0013, or 0014 on PPC Mac (Read 405 times) previous topic - next topic

wholder

Mar 12, 2009, 05:02 am Last Edit: Mar 12, 2009, 04:34 pm by wholder Reason: 1
I've been trying to use these new versions on my PPM-based Mac, but I can't seem to upload any sketches to either my Diecimila or Duemilanove (168) oards.  I can load a sketch in 0012 and upload it to the board just fine.  But, if I then try to upload the same sketch (using the same settings for the board and serial port) using either 0013, or 0014, I get this error:

  avrdude: usbdev_open(): did not find any USB device "usb"

Anyone know what I'm doing wrong?

Wayne

kg4wsv

The FTDI drivers are loaded, right?  When you do an "ls /dev/tty.*" (notice .) what do you see?

2 of the 3 macs I use for arduino are PPC, so it works in general.

-j


wholder

#2
Mar 12, 2009, 04:16 pm Last Edit: Mar 12, 2009, 04:34 pm by wholder Reason: 1
Yes.  The FTDI drivers are loaded, and they do work when I upload sketches using Arduino 0012 (and, I've even tried reinstalling them using the installers in the 0013 and 0014 builds.)  I also see the ports listed (twice, as always) in the serial port menu drop down.  This seems to result from some difference with the 0013 & 0014 builds.

Wayne

mellis

Weird.  That message implies that the IDE is trying to upload using a real USB device as opposed to a virtual serial port (which how the Arduino board should behave).  Did you edit your boards.txt file or preferences.txt file?  

wholder

Yup.  I trashed the preferences.txt file and let the IDE rebuild it and that solved the problem.  I tend to forget that not all the config information is in the downloaded build.  Sorry for the false alarm.

Wayne

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy